Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi everyone,

On the weekend I purchased a second hand 2008 CLK550 cab. It includes Nav, P1, P2, and most other options. I've searched extensively and think I have my phone (iPhone 4) issues solved (I've spoken to cellguy and know it's pre-wired for a phone and am adding bluetooth to use my iPhone 4 - he is great!)

What I'm having trouble with is:
1. The volume of music from the iPhone (being used as an iPod) when connected to the iPod connector in the glovebox is much lower than other sources (SAT, radio, CD, etc...). Is this something that should be fixed under warranty? Assuming not, I was wondering if this was the right solution:
Comand Online Ltd :: Mercedes iPod solutions :: Mercedes iPod line amplifier
Does anyone have experience fixing this issue? Is this part the right solution?

2. The existing (white) iPod interface in the glovebox does not charge my iPhone 4. Once again assuming this will not be fixed under warranty, how do I fix this? Is this the right solution:
Comand Online Ltd :: Mercedes iPod solutions :: Mercedes New iPod charging lead for A/B/C/CLK/GL/ML/R/CL/S/E/CLS/SLK

Any help greatly appreciated!
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,978 Posts
Welcome to the forum. You have obviously been doing your homework.

The new iPod cable should charge your iPhone 4 properly.

Where the MB iPod kit took the AUX jack (usually located in the glove compartment), there were frequently volume problems. MB came out with a very low powered amp to resolve the problem. Unfortunately, from the description in the link, I cannot tell if it will work in your W209. The writeup says "not suitable for ... current NTG2 (Pre MY2009 A/B/W203-C/CLC/ML/GL/R) iPod kits.
- It is OK for older NTG2 kits (the once that don't charge new iPods properly)."

The "CLC" seems to be a typographical error - CLS, or CLK? At the same time, you seem to have an "older NGT2 kit" that doesn't charge your iPod properly.

To be certain, I would contact the vendor or your dealer. My guess is, it will work - but I am not certain, and don't want to advise you to spend your money before checking. In either case, if the in-line amp works, it will solve your problem; if it is not for your car, it looks like a firmware update will solve the problem.
 

·
Registered
2005 CLK 500 Cabriolet
Joined
·
73 Posts
The comandonline guys are great and will be very helpful if you ask for their advice. The new cord will take care of charging your phone and probably isn't hard to install. There's some good instructions on line.

That might be a typo in the description for the amp. I think what it's trying to say is that the amp won't work with cars that have the Media Interface Kit which is the current equipment interface with the iPod and do charge the phone correctly.

Still, I didn't have much success with the amp. I ordered it with an iPod interface kit as well as the cable to connect my iPhone cradle to the interface kit thinking there may be an issue with the volume. I found I didn't need the amp as the volume on my system was fine without it. But when I did hook up the amp it didn't sound as good but that might be because my iPhone was overdriving the ampliflier causing distortion. Your results will probably be better.

Skylaw is the man for these questions and is a great resource for all things audio and telephonic for your Benz. The comandonline guys will take good care of you as well.

Good luck.

Steve
 
1 - 3 of 3 Posts
Top