Mercedes-Benz Forum banner

21 - 35 of 35 Posts

·
Premium Member
1983 380 SL
Joined
·
2,839 Posts
Be careful, your box... virtual or otherwise... might want to connect to a standard date and time server out on the internet. All my servers do that by design.


I don't remember ever receiving the "The StartKey will expire soon." "The StartKey expires in ___ days." message before. I got it today when I opened my VirtualBox VM to check for a part number. I may have gotten lucky opening it today because I don't know if there's an algorithm that ruins the startkey if you try to use it beyond it's date. It seems like maybe I just need to roll back the date on the machine because before, the message displayed "0". Maybe it won't work tomorrow. I will report back I guess.
 

·
Registered
'79 450SL, '04 CLK200 convertible; former A124, W210, A209.
Joined
·
1,874 Posts
I hope you get lucky Fonzi! I used to have a VM but stopped using it while ago since MB provided access to Xentry online, other than missing WIS it's pretty good.
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,338 Posts
Discussion Starter #23
Miko - Do owners in Europe/UK get free access to Xentry? Or at least to the parts section?
 

·
Registered
'79 450SL, '04 CLK200 convertible; former A124, W210, A209.
Joined
·
1,874 Posts
Hey Graham, sorry I should have clarified it's part of the MB Club membership kudos, more details in the link. Member Benefits | Official Mercedes-Benz Club Membership is open to anyone, I am actually making money off it due to discount for insurance and stealership that are worth way more than annual membership.
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,338 Posts
Discussion Starter #25
MBCA (US club) don't offer that. Maybe us Canadians should join the UK club :) Could use my VPN and a street address like 10 Downing st. :) There must be Daimler owners there?
 

·
Registered
'79 450SL, '04 CLK200 convertible; former A124, W210, A209.
Joined
·
1,874 Posts
Hehe, yep though may change after Brexit - citizens may be forced to drive Rovers and such ;-)
 

·
Outstanding Contributor
450slc5.0cab 280sl5sp 280se4.5 500se+500slAMG +250seStkW108 350sl4spdX3 500secEuro
Joined
·
22,563 Posts
I tried again today and rolling back the Virtual box date to 2018 again seems to have it working still (and without any expiration warnings again).

So I guess that process will keep me rolling.

I wonder if it would fix @MBGraham ‘s issue.
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,338 Posts
Discussion Starter #28
Fonzi, I think I tried that, but maybe I only changed the Windows 10 date? Which probably reset itself. Have lots of time on my hands these days, so will eventually have to try again.
 

·
Registered
99 SL500, 88 560SL, 97 S500, 87 BMW 635 CSi
Joined
·
65 Posts
Mine stopped working a while ago. No messages like that though. Just something about authorization. I used the on-line web site instead.
What is this on-line web site you speak of??
 

·
R/C107 Moderator
1986 560SL: '84 500SL: '84 280SL 5 speed: other 107s
Joined
·
32,355 Posts
Google free mercedes epc. There are several.
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,338 Posts
Discussion Starter #32
I tried again today and rolling back the Virtual box date to 2018 again seems to have it working still (and without any expiration warnings again).
I wonder if it would fix @MBGraham ‘s issue.
Ok, so I tried that. I actually changed the date in Windows 10 and turned off internet update.

Now, I at least get to the screen with EPC/WIS/Feedback boxes. (was only seeing Feedback box)
When I click on EPC, Java starts up and its says it is Downloading Application.
Then I get this (same happens if Internet is back on, but date still 2018)

So, what to do now....
epc error 2018-04-10 145958.png
 

·
Outstanding Contributor
450slc5.0cab 280sl5sp 280se4.5 500se+500slAMG +250seStkW108 350sl4spdX3 500secEuro
Joined
·
22,563 Posts
Ok, so I tried that. I actually changed the date in Windows 10 and turned off internet update.

Now, I at least get to the screen with EPC/WIS/Feedback boxes. (was only seeing Feedback box)
When I click on EPC, Java starts up and its says it is Downloading Application.
Then I get this (same happens if Internet is back on, but date still 2018)

So, what to do now....
View attachment 2627509
I didn’t change the date in my windows 10 machine, only inside the windows XP VirtualBox. That’s where my EPC runs.
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,338 Posts
Discussion Starter #34
I didn’t change the date in my windows 10 machine, only inside the windows XP VirtualBox. That’s where my EPC runs.
Yes, I realized that. But when I changed it in Win10, it also changed it in the VM. So I expected that to work. My problem seemed to be with validation certificates. Maybe their dates were later than the date I chose. Maybe I will try a later date. By the way, I don't really need EPC right now, but its good to have one more thing to work on :)
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,338 Posts
Discussion Starter #35
I didn’t change the date in my windows 10 machine, only inside the windows XP VirtualBox. That’s where my EPC runs.
So I tried different dates, tried setting date manually in Win10 as well as in VM. Still get that error message about the certificates. Everything works normally up until that point. Have to look for thread and see what djenka did.
 
21 - 35 of 35 Posts
Top