Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter #1
What is the cuase of this fault code (#13) Intake air temperature reading illogical? Where does the computer get this input?
Is this from the MAF sensor?
 

·
Premium Member
Joined
·
5,454 Posts
You don't say what year/model you have. Some 124s have an intake air temp sensor located in the duct betwen the air cleaner housing and the radiator support.
 

·
Registered
Joined
·
5,344 Posts
Likely either a bad, dirty or disconnected air intake sensor. It's located on the air intake pipe near the air filter. It's not an expensive part - should be $10-$20.
 

·
Registered
Joined
·
177 Posts
Discussion Starter #4
Boy, this thing got me worried... my car is a 1991 300e. I will take a picture of the engine tonight. The car is a project which I bought for $600 with a front end damage because of colision.
 

·
Registered
Joined
·
177 Posts
Discussion Starter #5
I tried to remove the fault code by removing, cleaning and reconnecting all the hose. It did not work, which of the units in the intake manifold could be the culprit? Help! I have attached a picture of the top of the intake (this is before I cleaned it).
[/IMG]
 

·
Registered
Joined
·
177 Posts
Discussion Starter #7
Here are other pictures which include when I first started working on it.

I will take another picture is it not shown here.
Will this be a cause for the car to fail smog test?
 

·
Registered
Joined
·
177 Posts
Discussion Starter #8
Here are other pics that might show what it is that is causing the problem:



I hope these images will show what is causing the fault code.
 

·
Registered
Joined
·
5,344 Posts
The sensor should be on the air intake pipe, a couple inches from the air filter housing. It looks like it might be damaged and it's missing the wire going to it.
 
1 - 9 of 9 Posts
Top