Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1999 ML430
Joined
·
47 Posts
Discussion Starter #1
Sometimes when I step on the gas at about 65mph to pass someone, the truck doesn't seem to want to go. It is also like this up hills. I want it to be like it should, press the gas and it goes, slam the gas and it takes off. But it isn't. Is there anything simple I can do to improve this performance?
 

·
Premium Member
ML430
Joined
·
2,662 Posts
How many miles are on your 430? I have the same year/model as you, and i use fule injector clenaers about every 2 other fillups (I travel a lot and have 109,000mi on mine). But mine does no seem to have that problem. It will get up and go whenever (sometimes when i dont even want it!). Good luck.
 

·
Registered
1999 ML430
Joined
·
47 Posts
Discussion Starter #3
I have 84k on it now. Any recommendations on brand of FI cleaner?
 

·
Registered
Mercedes "M32"
Joined
·
961 Posts
GLisella - 3/19/2005 6:26 PM

I have 84k on it now. Any recommendations on brand of FI cleaner?
Lucas Fuel Injector Cleaner works great for me ... I use it every few tanks.
 

·
Premium Member
05 500
Joined
·
6,489 Posts
ttaleric - 3/19/2005 10:05 AM

How many miles are on your 430? I have the same year/model as you, and i use fule injector clenaers about every 2 other fillups (I travel a lot and have 109,000mi on mine). But mine does no seem to have that problem. It will get up and go whenever (sometimes when i dont even want it!). Good luck.
You really use fuel injector cleaner that often? Do these things do more that clean the injectors? Is it a problem with the motor or the fuel? That sounds like a lot.
 

·
Registered
2014 ML350 BlueTec
Joined
·
2,626 Posts
l remember sometime ago..that someone of this forum mentioned that fuel injection cleaning products has a adverse effect of the converters....l've always used them..Any thoughts ?????
 

·
Registered
2000 ML430, 2000 C280
Joined
·
920 Posts
I heard that the pre-2000 Mercedes automatic transmissions are slow to downshift, thus causing a noticeable delay when passing. My 2000 ML430 takes off immediately when passing. Try downshifting manually.

DelJ



GLisella - 3/19/2005 6:18 AM

Sometimes when I step on the gas at about 65mph to pass someone, the truck doesn't seem to want to go. It is also like this up hills. I want it to be like it should, press the gas and it goes, slam the gas and it takes off. But it isn't. Is there anything simple I can do to improve this performance?
 
1 - 8 of 8 Posts
Top