Mercedes-Benz Forum banner

1 - 20 of 312 Posts

·
Registered
Joined
·
650 Posts
Discussion Starter #1
Upon startup my fan keeps running and does not stop at all until the car is off. What could the problem be?
 

·
Registered
Joined
·
650 Posts
Discussion Starter #3
Relay 26 (AC FAN)

I just replaced Relay 26 and it did not resolve the problem. What's the next thing I should do?
 

·
Premium Member
Joined
·
16,692 Posts
There is something wrong with the Power Steering pulley. At aprox. 22 secs. of the video look at how the pulley is turning. It is not turning at eng. speed and it should be.

1. Is there anything wrong with the P/S?

2. Are all dials off on the Heater-A/C controller?

3. Turn the key to pos. #2 (eng. not running). Do the fans come on?

4. If the fans are on in pos. #2, pull relay #26. Do the fans stop?
 

Attachments

·
Registered
Joined
·
650 Posts
Discussion Starter #5 (Edited)
1. Is there anything wrong with the P/S?
The steering is a little stiff

2. Are all dials off on the Heater-A/C controller?
Yes they are all off

3. Turn the key to pos. #2 (eng. not running). Do the fans come on?
No the fans do not come on

4. If the fans are on in pos. #2, pull relay #26. Do the fans stop?
 

·
Registered
Joined
·
1,588 Posts
Yea this is definitely atypical and I too noticed your power steering pulley spinning unusually fast. My power steering hose was leaking and the steering got pretty stiff (you can definitely tell the difference) I got my ps hose and clamp replaced and now there is no leak and the steering is back to normal.
 

·
Premium Member
Joined
·
16,692 Posts
Something is wrong with the belt or the P/S pulley or both. You should remove the belt and check everything first.
 

·
Registered
Joined
·
650 Posts
Discussion Starter #8
Thanks for the help. I will be going to a mechanic tomorrow to replace my leaking valve cover gaskets and will ask him what he knows about the PS Pulley. So that pulley is causing the AC Fan to spin?
 

·
Registered
Joined
·
1,588 Posts
Im not sure, I think the two are unrelated. The pulley is run by a belt and the fan by electricity

Thanks for the help. I will be going to a mechanic tomorrow to replace my leaking valve cover gaskets and will ask him what he knows about the PS Pulley. So that pulley is causing the AC Fan to spin?
 

·
Registered
Joined
·
650 Posts
Discussion Starter #10
It is interesting because I just had my Power Steering Pump replaced around this time last year. So that ps pulley is part of the ps pump? maybe the warranty would still be valid
 

·
Purple Moderator
Joined
·
21,633 Posts
After a very close look at the video I believe it is the video frame rate causing an optical illusion with that pulley, but get it checked out to play it safe.
 

·
Premium Member
Joined
·
432 Posts
Fans running all The time!?

I know this maybe out there. Somebody may have hard wired the fans ! the owner did not it. and we as a group have to look at what we have at hand. The owner may not be telling the whole history. Not on purpose , just may not know the relevance . IE , car accident , used 2nd owner?

I build a 170 - 180 degree Thermostat assys for aftermarket performance , It fits M-113 K & for other AMG models. This is a True new assy . Not just a bunch of holes drilled in the valve. What does this have to do with Bossjj98's 05 ML-350 . Not much . But most of the customers I sell modded T-stat assys to , usually try the -10* fan mod setting in the ECU , before they purchase a modded assys from me. This is something & found within the ecu and can be reset by the Star diag corrections. But their comments are Man ! The fans run a lot and are very noisy. So Bossjj98's may have a ECU issue? Attached are the screen shots\ BTW after the modded T-Stat is install the fan correction remains as it was reset too , but the fans now operate much closer to normal & the engine runs cooler.
Cheers _PTEngineering
 

Attachments

·
Registered
Joined
·
650 Posts
Discussion Starter #15
I know this maybe out there. Somebody may have hard wired the fans ! the owner did not it. and we as a group have to look at what we have at hand. The owner may not be telling the whole history. Not on purpose , just may not know the relevance . IE , car accident , used 2nd owner?

I build a 170 - 180 degree Thermostat assys for aftermarket performance , It fits M-113 K & for other AMG models. This is a True new assy . Not just a bunch of holes drilled in the valve. What does this have to do with Bossjj98's 05 ML-350 . Not much . But most of the customers I sell modded T-stat assys to , usually try the -10* fan mod setting in the ECU , before they purchase a modded assys from me. This is something & found within the ecu and can be reset by the Star diag corrections. But their comments are Man ! The fans run a lot and are very noisy. So Bossjj98's may have a ECU issue? Attached are the screen shots\ BTW after the modded T-Stat is install the fan correction remains as it was reset too , but the fans now operate much closer to normal & the engine runs cooler.
Cheers _PTEngineering

So are you saying I could possibly need a new ECU? How much do you sell them for?
I just found another post about this and I will check the fuse on top of the positive battery cable when I have a chance.
http://www.benzworld.org/forums/w163-m-class/1536021-suction-radiator-cooling-fan-high-speed.html
 

·
Registered
Joined
·
650 Posts
Discussion Starter #16
I also have a SRS light on and got the code B1875 Digital Crash Output Line Fault/Communication.... If that is linked to the ECU I think I might need a new ECU to fix both of these problems. (Fan and SRS) The dealer wants $141 an hour to diagnose the car
 

·
Registered
Joined
·
1,588 Posts
Try all other troubleshooting methods before you go to replace the ecu. I feel like that could lead to unwanted electrical (the worse) issues- but maybe I am just paranoid...and oh yea, some days...
 

·
Registered
Joined
·
650 Posts
Discussion Starter #18
I am heading to the dealer for a diagnostic at the price of $141 per hour... Does anyone know if they would say anything if they see my Airbag Emulator installed to my ML?
 

·
Registered
Joined
·
1,204 Posts
You probably could have diagnosed this yourself, and I doubt that the ECU is the fault. 43sqd presented some good diagnosing instructions that you should follow.
 

·
Premium Member
Joined
·
16,692 Posts
I am heading to the dealer for a diagnostic at the price of $141 per hour... Does anyone know if they would say anything if they see my Airbag Emulator installed to my ML?
It's your money, but going to the dealer is foolish in my opinion. You came to this forum for help and have done nothing on your own other than swapping a relay.

You haven't even investigated the P/S pump pulley or the serpentine belt issue. You could also have a Coolant Temp. Sensor issue or the fan clutch could not be working properly, and you have opted to visit the dealer.

PTE has put something in your head about the ECU (and he shouldn't have) and now you believe you might have a faulty ECU. No one one this forum has ever replaced an ECU because it was faulty.

If you still insist on going to the dealer, don't even mention the word ECU to them or you will be buying one from them. The emulator has nothing to do with the ECU, so get that out of your head along with the fact that the ECU is causing the fans to stay on. The fans are controlled by the AAM, not the ECU.
 
1 - 20 of 312 Posts
About this Discussion
311 Replies
20 Participants
bossjj98
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top