Mercedes-Benz Forum banner

1 - 20 of 42 Posts

·
Registered
94 s420 250kmiles
Joined
·
827 Posts
Discussion Starter #1 (Edited)
Factory sound system upgrades

So I've owned my 140 for about 6 months now and slowly I have been rebuilding the factory sound system, I started with the replacement of a few bad speakers and doing a small repair in the Bose amp, CD's sounded great but the volume knob on the Becker was infuriating, turn it up it goes down and turn it down and it goes on full blast, not to mention the subwoofer output on the Bose didn't work, so I set out to replace it with something a bit more modern, nothing fancy I just wanted an auxiliary input so I installed a few year old Panasonic hu my brother in law had in his car, front rear and sub 5volt preamp outs perfect for the Bose amp, then I acquired a 2channal bass amp from a friend to run the factory subwoofers on, hooked it all up and set the eq up to my liking and then tuned the output of the bass amp to balance out with the factory amp, it sounded amazing I was in love, but I couldent help but feel it was missing something... so i sat in the car and listened to almost every song on my zune and it hit me, the dash speakers didn't work! So I pulled them out checked them and they were in fine operating condition, so I figured I should just rewire them, so what I did was use the front speaker outputs on the headunit along with some spare a/d/s crossovers I had laying around from a previous car, turned on the radio and my jaw droped. Its done, and I only spent money on the replacement speakers from the bone yard. I'm happy :)

sent from my HD2 running Android 4.1
 

·
Registered
1995 Mercedes-Benz S420 (W140), 1997 BMW 740iL (E38), 2011 C300 Luxury (W204)
Joined
·
1,314 Posts
Good work, but I think the dash speakers you're talking about were only for the phone.
 

·
Registered
1995 Mercedes-Benz S420 (W140), 1997 BMW 740iL (E38), 2011 C300 Luxury (W204)
Joined
·
1,314 Posts

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts

·
Registered
94 s420 250kmiles
Joined
·
827 Posts
Discussion Starter #6 (Edited)
I don't think they are a part of the sound system either, the wire colors didn't seem to match with any on the amp and I put a toner on it and got no signal at the amp though It did pick up the toner signal it was not strong, which lead me to the same conclusion as sinned420.

sent from my HD2 running Android 4.1
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
I don't think they are a part of the sound system either, the wire colors didn't seem to match with any on the amp and I put a toner on it and got no signal at the amp though It did pick up the toner signal it was not strong, which lead me to the same conclusion as sinned420.

sent from my HD2 running Android 4.1
maybe it was the door speaker that echoed. i am not a fan of loud speakers anymore but the factory w140 sounds excellent. i use to like woofers and additional amps but now days it just gives me a headache.
 

·
Registered
1994 Mercedes S320 W140
Joined
·
71 Posts
my sound system has a quite hissing as the music plays and when you remove the key from ignition a thump sound from the speakers. more dollars :crybaby2:
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,642 Posts
Well done job SLOWHANDS .:thumbsup:
 

·
Registered
W140 600 SEL 1992, C 140 CL 600 1998 , W116 450SEL 6,9 1978 , 300SEL 3,5 1970 , 500SL R129 1991
Joined
·
108 Posts
no dash speakers

Factory Sound System Bose - no dashboard speakers. But a tiny single one behind the rearview- mirror.
Dashboard speakers where installed for carphones.
 

·
Registered
1995 Mercedes S500
Joined
·
59 Posts
dash speakers

My dash speakers have worked with my radio since I purchased my 95. As a matter of fact..my drivers side dash speaker is starting to work sporadically. Sometimes not working until I turn the radio up to push it. big difference with the sound when they are working correctly. I liken the sound to a symphony.
The overall sound is much more bass heavy when the dash speakers are not operating. Unless something was done with my car before I received it..I would say the dash speakers should work with the radio. My car even had the factors phone still installed when I purchased..so I do not think the system was ever altered.
 

·
Premium Member
1999 S600 Sedan, 1999 S600 w/ 4-pl seating, 1995 S600 Coupe, 2-1992 600SEL's, 2002 ML55, 1998 SL600
Joined
·
2,425 Posts
I am confirming that the two outlying dashboard speakers are ONLY for phone use, nothing else.

The small speaker behind the rearview mirror is for high notes from the car stereo system, as already noted.
 

·
Registered
94 s420 250kmiles
Joined
·
827 Posts
Discussion Starter #13
After more listening I have decided to swap out the a/d/s crossovers for an old set of focal utopia's they have a bit more adjustment in them, right now the highs are a bit bright.

sent from my HD2 running Android 4.1
 

·
Registered
Joined
·
1,675 Posts
Dash top speakers are for phone use only yes - Mine do not work and I do have Bose stock system.

I like the system however it is ridiculously bass happy and more of the mid range bass than a true subwoofer bass.

The system would have been even better with pillar tweeters in the front doors like new cars but then again this system was designed in 1991 in which its VERY good.
 

·
Premium Member
2012 E350 CGI Avant Garde Sport
Joined
·
1,931 Posts
The Bose Beta sound system that Mercedes-Benz used had an 11 channel amp, one channel per speaker.

4 subwoofers on the package tray
2 speakers in the back doors (one per door)
4 speakers in the front doors (two per door, one woofer one tweeter)
1 treble fill speaker behind the mirror
11 total

taken from the Bose pamphlet
 

·
Registered
1994 Mercedes S320 W140
Joined
·
71 Posts
On the subject of factory sound system. I've been losing my speakers one by one first the drivers door then the rhr then lhr then all the parcel shelf speakers now all that's left is the front passenger door and mirror speakers. when you take the key from the ignition there is a boom sound and a constant hissing with the stereo on. does anyone here know what might be happening or what to look at? any help is appreciated:confused:
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,642 Posts
On the subject of factory sound system. I've been losing my speakers one by one first the drivers door then the rhr then lhr then all the parcel shelf speakers now all that's left is the front passenger door and mirror speakers. when you take the key from the ignition there is a boom sound and a constant hissing with the stereo on. does anyone here know what might be happening or what to look at? any help is appreciated:confused:
90% its your AMP , 10% Tuner if you have it , i would send both of them in for repair /recon to make sure ,its not that expensive to fix at Lenny's repair shop . :thumbsup:
 

·
Registered
1994 Mercedes S320 W140
Joined
·
71 Posts
i've seen a few w140 amp on ebay i think they were second hand. that would be easy to just swap over, but i dont know if anyone here would advise against 2nd hand when it comes to w140 electronics?
 

·
Registered
94 s420 250kmiles
Joined
·
827 Posts
Discussion Starter #19
I would not buy it unless its confirmed that all the outputs are working, or at the very least the doors and center tweeter.

sent from my HD2 running Android 4.1
 

·
Registered
1994 Mercedes S320 W140
Joined
·
71 Posts
just had another look on ebay and there seems to be heaps of them and they are all guaranteed (or so they say) . seems the model year makes a differnece i may have to pull back the carpet and get a part number first
 
1 - 20 of 42 Posts
Top