Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Premium Member
2002 Mercedes E320 4matic sedan
Joined
·
50 Posts
Discussion Starter · #1 ·
only on a highway my ESP lights up, appears to apply brakes. what is going on? and i`m at the speed limit
 

·
Registered
Dallas, Texas
Joined
·
10,185 Posts
only on a highway my ESP lights up, appears to apply brakes. what is going on? and i`m at the speed limit
2002 E320 is W210.
All tires same size, same brand, same pressure? Any faults in traction systems?
 

·
Premium Member
2002 Mercedes E320 4matic sedan
Joined
·
50 Posts
Discussion Starter · #3 ·
2002 E320 is W210.
All tires same size, same brand, same pressure? Any faults in traction systems?
it`s not raining, and it seems to happen on a bend on the highway. i don`t do much highway driving but will go out this weekend and try to see when it happens. tires all same brand, pressure at 30lbs. i do have worn tie rod ends but not bad enough to fail inspections. waiting for time to got car on lift.
 

·
Registered
Dallas, Texas
Joined
·
10,185 Posts
it`s not raining, and it seems to happen on a bend on the highway. i don`t do much highway driving but will go out this weekend and try to see when it happens. tires all same brand, pressure at 30lbs. i do have worn tie rod ends but not bad enough to fail inspections. waiting for time to got car on lift.
You need to scan traction systems for faults. One or more wheel speed sensors is producing implausible value.
 

·
W210 Section Moderator
1998 E320 base sedan @ 215k miles
Joined
·
9,066 Posts
Possibly an alignment issue which becomes more apparent when steering wheel turning at high speed.

It is not that you have a fault in the ESP system as the ESP system works with false sensing of speed differential between the wheel sensors in relation to the steering angle sensor and the yaw sensor. If you had a fault with the ESP system you would have a ESP warning when the car is started.
 
1 - 5 of 5 Posts
Top