Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
'02 430 CLK Cabrio
Joined
·
18 Posts
Discussion Starter #1
My ESP keeps kicking on when I'm driving on the highway going around very moderate curves between 65 and 80. It seems to be getting worse. It kicked on 5 times this morning. Not a good feeling -- am I truly slipping around a curve and in danger? These are not sharp curves at all -- in my Ford Explorer (not exactly a good handling vehicle) I dont' feel any lean at all. The car, and therefore the tires, only has 15K miles on it. I'm going to take it to the dealer, but any similar experiences from anyone? This can't be normal. My tires don't appear to be excessively worn in any way.
 

·
Registered
2001 CLK 430
Joined
·
15 Posts
MY ESP ALSO

Yea man I have the same experience with my 2001 CLK 430. When it happens I just turn the ESP off. Yes I do wonder why it kicks when. It is annoying when you think you are driving fun, then all of a sudden the engine downs shifts.
 

·
Registered
2000 ML430 Skyview
Joined
·
73 Posts
May be a problem in the tranny.....my CLK does this very infrequently and my ML started ...

May be a problem in the tranny.....my CLK does this very infrequently and my ML started doing it. Since it was in the shop for other things they looked at it found some code and replaced a "transfer motor".

Unfortunately, the problem got much better but it still has done it once since the service.

Like you I am sure it should not be engaging ESP at that moment.....
 

·
Registered
'02 430 CLK Cabrio
Joined
·
18 Posts
Discussion Starter #4
Found my problem

My dealer replaced a faulty stop light switch. Apparently, the esp was reading that the brakes were being pushed harder than they were (?). Anyway, put about 1,500 miles on it since then and hasn't come on once, so I think the problem was fixed.
 
1 - 4 of 4 Posts
Top