Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
C230K
Joined
·
1 Posts
Discussion Starter #1
I have taken my C230K in five times for the same problem. The ESP and BAS malfunctions activate, but there is no problem with either one. The dealer has replaced the circuts each time, yet it hasn't been fixed.
Is anybody else having the same problem? The dealer has stated that this problem is common in the new C-class autos, but no one I know has had this problem execpt me.....
 

·
Registered
E500S4, C240; Sold ML320, '72 280SE, '67 280SL, '86 300E, '87 300SDL
Joined
·
383 Posts
yes

The c240 had it for a while, would come on for no reason every couple of weeks. I guess it could be for many reasons but on ours they changed some sort of sensor in the brake fluid reservoir, and so far no more ETS/BAS lights.
Also we had it on the ML (has ETS but not BAS) they changed the brake light switch, and this fixed it. A tech on another forum said the same thing regarding the brake light switch for ETS/BAS lights on late ML's.

hope this helps...
 

·
Registered
E500S4, C240; Sold ML320, '72 280SE, '67 280SL, '86 300E, '87 300SDL
Joined
·
383 Posts
again, this time brake pressure sensor.....
 

·
Registered
E500S4, C240; Sold ML320, '72 280SE, '67 280SL, '86 300E, '87 300SDL
Joined
·
383 Posts
I guess, I hope :)
 

·
Registered
CL230M
Joined
·
5 Posts
ESP/BAS

Had the same problem on my C230K. Intermittently a warning of ESP/BAS malfunction would come one, although there would be no noticeable degradation in performance.

Finally, while taking a turn that I normally execute on my way home, the ESP system kicked in, when there was no correction needed, I decided it was time to get it looked at. The dealer replaced the computer (which was on back-order) and all is well now. We'll see how long this one lasts.

Car is 5 months old.

Ben
 

·
Registered
2002 C240 Classic
Joined
·
3 Posts
i own a 2002 c240 aqnd today, the warning just popped up. okay, i skidded in the rain on ...

i own a 2002 c240 aqnd today, the warning just popped up. okay, i skidded in the rain on the highway by accident and then it went off. for the rest of the day (re-started car) the has been no sign of the warning coming up again. anyways, im off to get my pads replaced so i'll ask the dealer what they think when i go.
 

·
Member
'00 ML320 Elegance
Joined
·
8,965 Posts
Whenever any warning lamp comes on...

i own a 2002 c240 aqnd today, the warning just popped up. okay, i skidded in the rain on the highway by accident and then it went off. for the rest of the day (re-started car) the has been no sign of the warning coming up again. anyways, im off to get my pads replaced so i'll ask the dealer what they think when i go.
an error code is stored into the computer and the dealer can use it to determine what is wrong with your vehicle. As such, bring it in and let them have a look [:)]
 

·
Registered
Joined
·
4 Posts
BAS and ESP warning lights

I have a 2002 C240 with 7,500 miles and 6 months old.
BAS and ESP warning came on today. You can turn car off to reset but this is only temporary. Dealer to replace sensors--but from other posts looks like I may need some other electronic components replaced as well.

Seems like an inherent problem.
 
1 - 9 of 9 Posts
Top