Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
Proud owner of an Blue-Black (Charcol Gray) '91 420SEL
Joined
·
704 Posts
Discussion Starter #1 (Edited)
I need some advice on how to find a couple of parts in EPC.

I have been studying EPC engine areas in search of two parts.

I did find them in AutohauseAZ but really want to purchase the genuine
parts from M.B. as I have bad luck with a couple of their molded hoses.

I am looking for the fuel injector insulator and the deal for the top of the insulator.
AutohauseAZ has them listed as 1170700455 and 1160700077
but I can't seem to locate them to verify the part numbers.
I did find the actual injector and the 4 port hoses plus caps.

Thanks,
jimm1009

EDIT: I found a way to verify through Parts.com but I can't delete this post now for some reason even through advanced options.
 

·
Outstanding Contributor
1990 500SL, 1986 500SEC
Joined
·
1,798 Posts
I know you said you figured it out but for anyone searching, use F11 to cross reference part numbers in the EPC.

Many times Autohaus uses a very similar if not identical part number to the MB one. I just copy and paste into EPC under F11 and verify it is what I want.

Then compare prices with Parts.com or your dealer, sometimes it is surprising :thumbsup:
 

·
Registered
2013 MINI Copper S Clubman, '84 300CD-weekend car
Joined
·
10,152 Posts
The epc has a part number search function, let us know if you require further assistance.
 

·
Premium Member
1991 560 SEC 1994 E500 2014 E350 Cab
Joined
·
7,029 Posts
I have widows 7 pro, loaded up Mozilla, deleted java and rebooted added java back. Same story, HP certificate error happens in Mozilla and in windows IE. any help? I also turned off firewall, no joy. EPC kickin my arse!
 

·
Registered
1979 280SL, 1984 280SL
Joined
·
5,654 Posts
I have Vista and my wife just installed Explorer 9. I can't make the EPC work anymore. Uninstalled and re-installed Java several times. No luck. It's a real pain- I can't look anything up!!
 

·
Registered
1989 560SEL, 1974 450SL
Joined
·
223 Posts
Try this:

Make sure you aren't running any Java applications.

Open the Java Control Panel (search for "java" it in your Start Menu search bar or manually find it in the Windows control panel).

In the "Temporary Internet Files" section of the "General" tab, click "Settings..." then "Delete Files..." In the window that comes up, make sure both check boxes are checked and hit "OK" for that box and "OK" again for the Temporary Internet Files Settings box.

Log into EPC again and try to launch the application.



If, after having done the above, it still doesn't work, click on the "Security" tab, click the "Certificates" button, and remove any existing Snap-On certificates. After you have done so, retry EPC again.
 

·
Registered
1979 280SL, 1984 280SL
Joined
·
5,654 Posts
Thanks for the info. My wife just went thru your info, did it all and no success.

There are 2 Daimler certificates, but I would think those are for the EPC.
 

·
Registered
Proud owner of an Blue-Black (Charcol Gray) '91 420SEL
Joined
·
704 Posts
Discussion Starter #8
It is a problem with the PEC site.

I e-mailed them five days ago, received an automated answer "we will contact you" and NOTHING since.
The Java download appears to function but just not with the EPC site.

I have tried this on four computers and no-go on any of them.

Two of them have not been altered in anyway and the EPC site is no longer functioning on them either.

I guess M.B. does not care to help or they don't know what to say about the problem at this time but either way they should at least say that they are going to look into it.

I have some small vacuum elbows to look up to finish my engine and can't do it. It blows to say the least!
:crybaby2:

jimm1009
 

·
Registered
2013 MINI Copper S Clubman, '84 300CD-weekend car
Joined
·
10,152 Posts
The epc is working normal for me, let me know if I can help anyone.
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
Java has been buggy for the last two weeks. it is recoended to uninstall java and reinstall it. then uninstall epc and reinstall it and that should fix it.

That said, I have not had any trouble with EPC or Java.
 

·
Premium Member
1991 560 SEC 1994 E500 2014 E350 Cab
Joined
·
7,029 Posts
been there, done that twice lol.
 

·
Premium Member
2012 CL550 4MATIC Coupe
Joined
·
9,992 Posts
I have a master parts list which has all of the major parts in it, including most of the rubber elbows for the vacuum system.

Pm me your email if you want it.
 
1 - 12 of 12 Posts
Top