Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
2001 E430
Joined
·
30 Posts
Discussion Starter #1
Hello guys,

try this one. I changed the CAT last week and recently changed the MAF. all is 1000% better idles great at or around 500 rpms at idle etc etc... I recently noticed a slight rev of engine at start up. it goes to about 1000 then real quickly goes to 1500 the drops fast to 500 and stays there. it drives fine???
I think befor i changes the CAT and MAF it reved a liitle at start but not like this withe the slight quick jump. Do you think is bad??? I did not change the O2 sensors nor the fuel filters witch i plan to do..... I quess it could be the O2 sensors????? ANY ADVICE..

thanks
chris
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Hello guys,

try this one. I changed the CAT last week and recently changed the MAF. all is 1000% better idles great at or around 500 rpms at idle etc etc... I recently noticed a slight rev of engine at start up. it goes to about 1000 then real quickly goes to 1500 the drops fast to 500 and stays there. it drives fine???
I think befor i changes the CAT and MAF it reved a liitle at start but not like this withe the slight quick jump. Do you think is bad??? I did not change the O2 sensors nor the fuel filters witch i plan to do..... I quess it could be the O2 sensors????? ANY ADVICE..

thanks
chris
Its quite normal:thumbsup:
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
Hey, Chris. +1 to Eric's post; now that you got rid of the rattling cat you're hearing everything else anew. :D

Are you closing in on 100,000 miles? That's the O2 sensor spec.

Take care and enjoy the ride,
Greg
 

·
Registered
2001 E430
Joined
·
30 Posts
Discussion Starter #4
Yes I have 120.000 miles. and i also get a slight jerky hesitation when i am in traffic and have to stop sudden and the excel again???? like i said could this be the fuel filter as well as the o2 sensors???. ??

thanks
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
Yes I have 120.000 miles. and i also get a slight jerky hesitation when i am in traffic and have to stop sudden and the excel again???? like i said could this be the fuel filter as well as the o2 sensors???. ??

thanks
I'm not sure I'd feel comfortable guessing at all the things it "could" be. I'd start with maintenance items that are due or past due (or that you don't know if they've ever been done). Spark plugs, AT fluid and filter, O2 sensors, fuel filter, two of which you've mentioned. When your maintenance items are all up to date if you still have an issue then it's time to dig in, but start with service items first.

Take care and enjoy the ride,
Greg
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Plus 1 to Gregs post and if the tranny fluid has not been changed then do it now and dont wait :thumbsup:
 

·
Registered
2007 E550, 2007 GL450
Joined
·
479 Posts
Yes I have 120.000 miles. and i also get a slight jerky hesitation when i am in traffic and have to stop sudden and the excel again???? like i said could this be the fuel filter as well as the o2 sensors???. ??

thanks
Had the exact same thing in my 1998 E430, mileage about 150,000 Kms. It was both pre-cat O2 sensors, the code was 'sensors aging'. It happened most when decelerating and then accelerating again (like around a corner). The car would stumble, no pedal response, then it would fire up again.

Replaced them and the car is running perfectly!
 

·
Registered
2014 E350 4Matic sedan, 68K miles (purchased Jan 2017)
Joined
·
855 Posts
hey all - i have done everything here EXCEPT o2 sensors. what is the best place to buy them (ohlord - autohaus?). the only issue i'll have is making sure i order the right ones as i believe there are 4.

i'm not getting a code but i do notice some slight jerky/hesitation sensation happening in traffic. idle RPMs just slightly over 500.
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
hey all - i have done everything here EXCEPT o2 sensors. what is the best place to buy them (ohlord - autohaus?). the only issue i'll have is making sure i order the right ones as i believe there are 4.

i'm not getting a code but i do notice some slight jerky/hesitation sensation happening in traffic. idle RPMs just slightly over 500.
What's your mileage? They're due at 100K, just like the plugs. Fuel filter is due before that, those can also affect driveability. If you're ready for O2 sensors your first question is whether you're doing them or having them done, if you're doing them and want the easiest changeout buy the OEM ones with the connectors already on them. Lots more expensive but no rewiring/splicing etc. needed. You can get them from lots of places, but in NO event buy them from Ebay. Too many "replica" parts out there, deal with a reputable vendor. autohausaz is a good source for the OEM or the "splice-in" universals, you'd need the four-wire jobs if you go the latter. (Actually if you're having them done buy the OEM as well; after you pay labor rates for cutting and splicing it's probably a wash.) :)

Take care and enjoy the ride,
Greg
 

·
Registered
2014 E350 4Matic sedan, 68K miles (purchased Jan 2017)
Joined
·
855 Posts
thanks greg. spark plugs, fuel filter, tranny fluid & filter, etc. done at 95K miles; current mileage is 98.5K. i always go OEM!
 
1 - 10 of 10 Posts
Top