Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Have you done anything to the engine lately? Or did it just start making this noise? Check your oil level. I just rebuilt my 190E's engine and the valvetrain sounded like that but louder.....it took 45 mins of idling to quiet it down because the hydraulic lifters had no oil inside the reservoir so that was why it was noisy.
 

·
Registered
Joined
·
22 Posts
yes i did but it was easy for me as i had a w124 before. it made similar noise when the tensioner pulley and the damper is gone (m102 engine)...it's worse when the ac kicks in or the steering is at an angle (pump under load)...hope it helps

:)
 

·
Registered
2006 S500 AMG Wifes Rig Hillbilly Girl 02 ML320
Joined
·
2,332 Posts
You might take off the belt and run for a VERY SHORT TIME and listen if you hear any noise ! If not I would be looking for something on my accesories? I have a noise on my 93 300SE that with my little doctor listening tool seems to be coming from the PS pump? I poked around on the other assecories but the PS was the loudess! Wonder how hard to replace it?

Smokie
 

·
Registered
Joined
·
6 Posts
Dear friend I has Mercedes S 320 model 1998: I have problem in it
• When I need to start up and change the gear from N to R or from N to D there is little shaking
• At driving if I slow down my speed for bumpy then press the fuel to speedy the engine shaking continually until I stop the car and switch of the car and restart again the engine bake normally and stable
• Pleas tell me what’s the reason.
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
There are a few things that would cause this symptom.

Start with the cheapest first
1) Spark plugs and spark plug wires. If one of the wires are bad then it will cause this shaking.

2) cap and rotor- if its old then moisture could have gotten in and caused bad contact with connections.

3) Crank Position Sensor- $130 bucks. Its a magnet so it can corrode but will give you the out of gas feeling at any speed or while idling at a red light or stop sign.

4)Ignition coil- weak spark or intermittent spark causing funky idle speeds

5)EZL- Ignition Control Module- (black box on drivers fender) very expensive, this causes no spark too so to check when your car is acting up, pull each spark plug wire out and check for spark by grounding it on exhaust manifold with an old spark plug. It should be no spark for all your wires in this case or very weak.
 

·
Premium Member
1998 140.070 CL500, 1966 406.121 U65
Joined
·
1,463 Posts
Runninrebel211,

While your suggestions are good, you'll have to realize, that the latest version
of the M104, M119 and M120 had coil on plug -> no high tension leads (not in normal sense, at least), no distributor, and no EZL.

kava1970, I think you'll have to read some error codes, to have an idea
of which part of the systems it relates to. But, as Runninrebel suggest, it could
be ingition related or crack shaft sensor. Or, plain mechanical, the
motor mounts.

br,
syljua
 

·
Registered
1993 190E 2.6, 1990 300SEL, 1992 300SE, 1992 400E, 1987 190E 2.6 murdered by my brother.
Joined
·
1,291 Posts
Runninrebel211,

While your suggestions are good, you'll have to realize, that the latest version
of the M104, M119 and M120 had coil on plug -> no high tension leads (not in normal sense, at least), no distributor, and no EZL.

kava1970, I think you'll have to read some error codes, to have an idea
of which part of the systems it relates to. But, as Runninrebel suggest, it could
be ingition related or crack shaft sensor. Or, plain mechanical, the
motor mounts.

br,
syljua

Syljua you are correct. I keep forgetting that the later models dont have a distributor and are direct fire. Been sick lately. Happens when you work on cars in pouring rain. So being tired and sick....I wasnt thinking straight. :D
 
1 - 14 of 14 Posts
Top