Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
My Engine Malfunction Lamp went on on my E350 2010 at 65K. I recently had my 60K service done at the dealer. My service rep says that as long as it is not flashing no damage will occur to the car. There is no change in performance nor any noticeable engine noise and I have checked all the usual stuff such as the gas cap,,, etc. Since it has remained on I will book an appointment for a check tomorrow anyway.

Does anyone know if this could be a serious problem? Is it covered by the emissions warranty? This car has been well treated and all dealer maintained so it would surprise me if it wasn't covered.

Regards and Safe Driving to All,

Kris
 

·
Registered
Joined
·
3,523 Posts
My Engine Malfunction Lamp went on on my E350 2010 at 65K. I recently had my 60K service done at the dealer. My service rep says that as long as it is not flashing no damage will occur to the car. There is no change in performance nor any noticeable engine noise and I have checked all the usual stuff such as the gas cap,,, etc. Since it has remained on I will book an appointment for a check tomorrow anyway.

Does anyone know if this could be a serious problem? Is it covered by the emissions warranty? This car has been well treated and all dealer maintained so it would surprise me if it wasn't covered.

Regards and Safe Driving to All,

Kris
Kris, The forum is divided into model specific sections. This is the W210 section...you have a W212.
 
1 - 2 of 2 Posts
Top