Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
'97 C200 Blue
Joined
·
78 Posts
Discussion Starter #1
Hi All,
I have a '97 c200 recently I have had an intermittent problem in that when I start the car I can hear a knocking sound only while idling, then when I go to accelerate the engine hesitates but continues to run fine, it will then hesitate every time I stop and go to accelerate again. After a while it seems to go back to normal and the knocking sound disappears, hasn't stalled on me yet but feels like it wants to. Any ideas on what may be causing this plugs,coils or Maf sensor perhaps? There was about a week between the first time it happened and the next.
Any thoughts greatly appreciated.
 

·
Registered
1995 C280 (165K mi)
Joined
·
1,534 Posts
this can be a lot of things. how many miles on it?

check for codes. replace spark plugs if it has been long.
 

·
Registered
'97 C200 Blue
Joined
·
78 Posts
Discussion Starter #3
Has about 276000km's on it not sure when the spark plugs were last changed, but it is serviced regularly. Sadly I don't have a code reader as it is the old OBD1 38 pin connector. Head gasket and transmission have both been rebuilt, usually a very reliable car, as I said it starts and idles normally even when it starts to make the knocking sound, but I get that hesitation when I accelerate from a stop. Just a bit unnerving when I need to move quickly at corners or intersections. Thanks for the reply.
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
1,653 Posts
Has about 276000km's on it not sure when the spark plugs were last changed, but it is serviced regularly. Sadly I don't have a code reader as it is the old OBD1 38 pin connector. Head gasket and transmission have both been rebuilt, usually a very reliable car, as I said it starts and idles normally even when it starts to make the knocking sound, but I get that hesitation when I accelerate from a stop. Just a bit unnerving when I need to move quickly at corners or intersections. Thanks for the reply.
Sorry to say, but, No scanner = looking for a needle in a haystack, in your situation.
Autel md802 scanner is what you will need, as an example, along with the correct 38pin adapter to plug into.
You could spend $$$$ throwing parts at it yourself, if you have deep pockets, but your best off to invest in a decent scanner and use the forum members to assist OR, even go borrow one from a friend or neighbor, or nearby member. :)
 

·
Registered
'97 C200 Blue
Joined
·
78 Posts
Discussion Starter #5
Thanks khomer2, I will look into getting the scanner mentioned. Have the car booked in at my mechanics Friday hopefully he has a scanner and can diagnose the problem.
 

·
Registered
'97 C200 Blue
Joined
·
78 Posts
Discussion Starter #6
Just a quick follow up, took the car to mechanic and code came up for crankshaft position sensor. Sadly he didn't have time to replace it but he cleared the code, hopefully I won't have any problems till he can get time to replace it.
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
1,653 Posts
Just a quick follow up, took the car to mechanic and code came up for crankshaft position sensor. Sadly he didn't have time to replace it but he cleared the code, hopefully I won't have any problems till he can get time to replace it.

This may assist for a DIY. pretty straight forward.

 
1 - 7 of 7 Posts
Top