Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there, have been lurking for a while but this is my first post I think!

I have a pretty rough 89 W124 300TE, which has any number of irritating problems - none of which stop it from being my daily driver :) and it was ridiculously cheap so..

So i have been chipping away at these multiple issues, but the one that I truly don't know where to start on is the missing slightly at speed. Basically it is fine most of the time (although it does idle slightly rough which is not that much of a concern) but fairly regularly it hesitates when at road speed. It is fine if you put your foot down (and pulls like a schoolboy when you do) but it is annoying when it does happen.

Any ideas on where to start looking?

This is the beasty here :thumbsup:

 

·
Immoderately Caffeinated/ Vintage Moderator
T5
Joined
·
17,007 Posts
You haven't said what you have done so far but I would try the obvious and easiest first if you haven't already.

Plugs, leads, coil and or rotor and distributor cap. Then have a squiz at the duty cycle.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
You haven't said what you have done so far but I would try the obvious and easiest first if you haven't already.

Plugs, leads, coil and or rotor and distributor cap. Then have a squiz at the duty cycle.
I have done nothing really, jut got in it and driven. It had been sitting unused for a couple of years, so I expected some issues... It needed a fuel pump replaced to get it to run ok in the first place.

This is my list of faults to fix;

Fuel pump - done
Hatch Struts - done
Broken front seat - done
Front discs
Cam leak - got the parts
Coolant - sort of done
fuel surge
Interior lights
Warning lamp
Chipped headlight
Aircon
Passenger window switch
Hatch trim
Towbar
Idle/vac leaks

I will probably do the cam cover leak over xmas, so will look at the ignition stuff then.
 

·
Immoderately Caffeinated/ Vintage Moderator
T5
Joined
·
17,007 Posts
Where are you anyway? You sound like an Aussie.

Good luck with the aircon:crybaby2:
 
1 - 5 of 5 Posts
Top