Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
clk 320
Joined
·
57 Posts
Discussion Starter #1
My engine fan light light has come on. If in traffic,the car will run hot. Is this the electric fan gone bad? Any help will be great.
 

·
Registered
2003 SL500, 2000 S500 Lorinser, 2006 SL, 06 Bentley GT
Joined
·
111 Posts
Between 80 and 100....I believe the thermostat is an 89 degree...So don't worry your not overheating. I get stuck in horrible traffic every day, I will take a picture of my gauge.
 

·
Registered
clk 320
Joined
·
57 Posts
Discussion Starter #4
It runs at about 90. If I sit long enough in traffic, it will run into the red. I believe it might be the electric fan motor.
 

·
Registered
clk 320
Joined
·
57 Posts
Discussion Starter #5
It runs at about 90. If I sit long enough in traffic, it will run into the red. I believe it might be the electric fan motor. I hope someone can help before I pay the dealer $ 150.00 to look at it.
 

·
Registered
88 420 SEL, 99 CLK 320 Cab-SOLD
Joined
·
96 Posts
electric fan

the fan should be coming on with the engine on and engine temps around approx 85c

if it isnt, then try spinning the fan with the key off to see if it spins freely, if its locked up you need a new fan.

next check the connection for the fan, it should be on the drivers side next to the fan.

next check the fuse box and see if you have any fuses blown out.

if its not one of these 3 things, then you need to check the relay to see if its working, check the temp sensor, and then check the wiring harness to see if it is damaged.

good luck
 

·
Registered
clk 320
Joined
·
57 Posts
Discussion Starter #7
Ty you Palm,I'll check all of thoses items.
 

·
Registered
2001 CLK55
Joined
·
254 Posts
My fan comes on for about 6 seconds and then shuts off, then about 1 minute later it will do the same thing, it just does it over and over. I was wondering if there is some kind of voltage regulator or relay, and where it's located. I thought the fan was supposed to stay on until the car cools down. But i can't see it cooling the car in 6 seconds. I'm not sure what else to check.
 
1 - 9 of 9 Posts
Top