Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Mercedes C240 Elegance 2001 automatic
Joined
·
5 Posts
Discussion Starter #1
Hello,

I have a C240 2001, automatic transmission, almost (127000km).

The past months i was having problem with the engine diagnostic warning lamp. Although it lights up no problem seems to have [since i get no report of damage or because after a reset by switching off/on the engine the car reenters from the safe drive mode (block at low speed and rpms)].
A friend invited me to pull of the battery to reset the cpu of the car so after that the light went off.
In the first occation (within a month) i took it to a Mercedes official repair shop and they diagnosed....nothing.
they said to me that there was no error memorized and my procedures didn't affect the registration.
So their advice...don't think about it, it was somekind of a temporary fault with no meaning.
I drove my benz for about 100km from the workshop [i must say at a speed almost 200 km/h] and in a moment the engine diagnostic warning lamp lighten up again, putting me into safe drive mode.
Switching off/on engine managed to return home keeping the rpms at 2000 and the speed under 80km/h.

I noticed that the car starts to shake when with no gear (position N) i increase the rpm of the engine to its upper limiter (almost 5000 rpm).

Please help. Any thoughts would be appreciated.
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
well now that the check engine light came back on, the code is now stored in the ME control unit, take it back and have it rechecked. dont do anything to clear it.
 

·
Registered
C230K Sport Sedan
Joined
·
5,368 Posts
Welcome to the forum!

The codes are meant to help you diagnose problems. Shooting the messenger is not the way to fix your car. Get the code checked at an Autozone and let us know what the code is, we maybe able to help.

Also, put your location and car model in your profile, makes it easier to help in the future. It could be that in your country they don't have OBD2 like in the U.S.
 

·
Registered
2017 GLC 300 4Matic fully loaded... but for the heated steering wheel. Stupid previous owner! 😠
Joined
·
1,142 Posts
I also have a code. P0432. Light came on twice already. I used my scanner to clear them and, although it took three weeks to come back the second time (this passed Sunday), it just came on today, again. Same code. My scanner said something along the line of an Inefficient Catalyser... The car does have a little exhaust leak, I wouldn't be surprised if it may be the cause. It is still under warranty, so when I have the time, I'll drive to the nearest dealer and have them fix it. Anyway, what are the most probable causes of a P0432?
 

·
Registered
Mercedes C240 Elegance 2001 automatic
Joined
·
5 Posts
Discussion Starter #5
thank you for the reply

I am sorry i couldn't reply earlier.
first of all thank you all for your replies

i took my benz to be looked and they didn't say anything about a code
they just said that there was a problem with the sensor that controls the air input
to engine..(i ll came back with more details in another msg)
so i paid for about 450 euros to have it changed.
It seemed that the maximum input was almost 190 Litre of air / 1 hour (at 5000rpm) and after the install of the new item it went to 390 litre of air /hour (at 5000rpm)
anyway they calmed me down about the motor shaking and they defined it as normal for the model.


now i am on a trip to Italy, i made over 2500km with a decent speed and yet no sign of the problem.
thank you all
keep the good job.
 
1 - 5 of 5 Posts
Top