Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
SL60
Joined
·
46 Posts
Discussion Starter #1
My car has been garaged since early november. Today I went to start the car, I noticed that the engine "clicks" repeatedly and won't go away. As I revved the engine, the clicks clicked faster. The clicks seems to be emanating from the driver side of the engine. I usually start the car every 2-3 weeks and this is the first time it clicked. Any clues what might be the source for these clicks, and what might be the solution to this problem?
 

·
Registered
1990 500SL
Joined
·
146 Posts
i'm experiencing the same clicks! altho my SL is my daily driver the clicks seem to go away after i drive it a bit. they are only present after i let the engine sit over nite in the cold do you exhibit the clicking. ne one have ne ideas?

Thanks,
Devon
 

·
BenzWorld Elite Member
2004 SL55, 2006 Range Rover Supercharged, 2013 Infiniti M37
Joined
·
312 Posts
"Sounds" like the lifters to me.
As the car sits & the oil drains to the pan
the oil in the lifters slowly drains out.
Typically upon start up the oil pressure will
fill the lifters.

I would suggest checking to make sure there is adequate oil pressure. An oil change would also
be a good starting point.

Brett
 

·
Outstanding Contributor
'03 SL500, '03 SL55, '97 SL320, (2) '91 300SL, (2) '91 500SL, '00 S500 -- all for sale
Joined
·
4,235 Posts
Mercedes issued a Service Bulletin on this ticking problem. You can read about the SB and the fix here: http://pages.prodigy.net/jforgione/MB_lifter.html.
 
1 - 4 of 4 Posts
Top