Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1985 300d CA Edition
Joined
·
39 Posts
Discussion Starter · #1 ·
My #2 fuse blew out. And everytime i put another in it shorts it immediately. At first i thought it was my nice radio causing problems. But i disconnected and still having trouble. I wasted like 5 fuses already. All my interior lights, radio, hazards...everything link'd to fuse #2 is out. Any suggestions?
S.M.B (Save My Benz :()
 

·
Registered
83 300 d t
Joined
·
699 Posts
sounds like wire insulation worn off some where and hot line is touching ground. have you pulled on any wires ????
 

·
Registered
1985 300TD Wagon
Joined
·
408 Posts
Somewhere there must be a short circuit,
Did you disconnect the radio at the fuse box? If not, this would be a good start.
Still the same result? Then you need to take all wires from fuse 2 away, and connect them one by one again checking the fuse each time again untill it breaks. Then you know which part of the electrical circuit you have to search.
It is possible to find a part of the harnas gone missing due to shake or pressure in the past years, but this is a rare fault in a W123 ( and almost always caused by a poorly performed repair).
Good luck
 

·
Registered
1985 300d CA Edition
Joined
·
39 Posts
Discussion Starter · #4 ·
Well i have tried a couple of things, i took off the radio. and it still seems to short the fuses. I need to check some other elements which involve #2. For some reason my trunk is stuck. It usually will unlock itself in a day or two. I know its due to the vaccum lines being old or clogg'd. But it seems highly ironic so much crap has happend in a relatively short amount of time.
Shall i just take it to the mechanic? time is of essence...
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Pat, you could join the mini meet and we can diagnose it on the spot :D

Check all grounds.

Front right turn signal.
Behind instrument cluster.
Near antenna motor.
Inside the front dome light.
Main ground near oil filter canister.
Battery ground along with emergency jumper lines.
Taillights.
 

·
Registered
1985 300d CA Edition
Joined
·
39 Posts
Discussion Starter · #6 ·
Nice

Yea lemme know when you going to have it...i could use that long drive, restore some confidence in ole' faithful... yea it would be nice to be more familiar with Southern California...And maybe i can visit you guys in the future because i go to Long Beach 4x a year...U have you have my cell rite?
 

·
Registered
2015 ML350
Joined
·
484 Posts
P-Rex85, there are a few pieces of equipment you'll have to disconnect one by one to troubleshoot your electrical problem. Equipment on #2 fuse is : Clock, Warning Flasher Hazard Switch, Auto Antenna, Front Dome Lamp w/ Switch, Rear dome lamp w/ switch, Relay II window lift, and trunk lamp. I won't speculate on the possible culprit. Years ago while t/s a fuse blowing type electrical problem it turned out to be a cigar lighter element stuck in the down position. Your problem may not be as serious as you think. When you find the problem you'll know it and it will be evident. You should be able to gain access to your trunk by manually unlocking it with the master key. Please let us know what you find........
 

·
Registered
1985 300d CA Edition
Joined
·
39 Posts
Discussion Starter · #8 ·
Halo-Lujah!!!

Ohh man... was taking all this crap apart and doodling w/ stuff and ended up taking my Instument cluster off and i was teasing about my lil clock being the problem...But ever since i had the car the clock was out and it never affected the car before....i was starting to lose faith...and decided to place a fuse in and check the voltage and sure enough...Stupid lil clock had me driving w/o radio and lights ect... my trunk is still messd up...hopefully she'll fix it herself like always...or she'll have to wait till next weekend...THanks alot Thorgod u gave me hope when u said its probably not a super big problem...And it wasnt... ANyone got an extra Tach they wanna sell?
 
1 - 8 of 8 Posts
Top