Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
The driver window switches are no longer working. The passenger switch works. The speaker on the driver side is out. The rear window switch works. The driver seat doesn't move. Checked the fuses in the front and rear. Any suggestions?
 

·
Registered
CL500, CL500, 190E 2.6, 420 SEC, 350 SL
Joined
·
176 Posts
Sorry mate, I have the same car, same year but I haven't experienced anything like this.

The fact the fuses are intact and its geography related might suggest that it's a physical break somewhere. There were comments a few years ago that the plastic gaiters that link the door controls to the main wiring loom were prone to failure, or could sever after lots of use. Not sure if this is your problem, but it certainly sounds like a hard link has gone somewhere.

Are all the window switches on the drivers door panel knacked? Or do any them work? Do your seat heaters or ventilators work?

These cars are great for the toys but not so great for the electrics when the gremlins arise...
 

·
Registered
2002 CL500
Joined
·
71 Posts
I have the same problem - driver's side switch isn't working. Initial symptom was that the driver's side window wouldnt fully close after exiting the car (it opens slightly when you open the car door). A few days ago, when I got in the car, I could still close the window after shutting the door. Yesterday I had to press the reset button (located on the body, underneath the door latch) once or twice to make the window work. Now the entire driver's side window switch apparatus doesn't work. I noticed on the drive home tonight that the apparatus wasn't illuminated at all, either (while the passenger side was). Thus I think its either a connection/wiring issue, or just that the switch apparatus is bad. A buddy of mine owns a repair shop, will post follow-up once I know what the issue is.
 

·
Registered
Joined
·
5 Posts
The power wire in the harness between the drivers door and the car usually is the cause of this. Pull the cover off from the door side and open up the cover and ther eis a broken wire. I cannot remember the color of the wire but it's about a 12 or 14 gauge wire. You can get a butt connector and crimp the two ends back together. Hope this helps.
 

·
Registered
Joined
·
20 Posts
The power wire in the harness between the drivers door and the car usually is the cause of this. Pull the cover off from the door side and open up the cover and ther eis a broken wire. I cannot remember the color of the wire but it's about a 12 or 14 gauge wire. You can get a butt connector and crimp the two ends back together. Hope this helps.
Yep. I agree. I had the same problem with drivers side speakers all not working. Pull open the accordion between the door and body. If yours is like mine, there's 3 sets of covered wires. One is speakers, One don't know all but it has main power to the door's innards and there's another one. My speaker wires were the bottom of the three and were color coded pink for one and green for the other(ie pink/brown and Pink and green/brown and green).

I attached short wires to the 3 broken ones, taped them up and the door speakers worked. Seems to be a weak link for such an expensive car. In the 20 odd cars I've owned, I've never seen this before. I think Lucas (prince of darkness) is selling old mg wiring harnesses to the germans now. :crybaby2:
 

·
Registered
2006 S500 4matic, 2004 CL55 AMG, 1986 560SEC
Joined
·
71 Posts
Door Conduit

Is there a way to open the rubber conduit in the front door jamb without having to cut or ruin it in any way? I have the same issue of the speakers not working in the drivers door.
Is it easy to spot where the break is in the cable once you have it open?

Thanks!
Elm
 

·
Registered
2001 cl500
Joined
·
1 Posts
Hi. I have a 2001 cl500 and the driver side window drops when I open the door. And it takes about 2 hours to go back up.
If I enter from the passenger side I can manipulate the window up and down. But as soon as I open the driver door. It goes down. And won't go back up.
Anybody please help..?
 

·
Registered
2003 Cl600 under full restoration after accident, 1993 3000GT
Joined
·
96 Posts
Check the user manual for programming the windows.

Pres the window up button for a couple of seconds after the window is fully closed.

If this does not work, then it could be a issue with broken wires going to the door (common problem) they stretch over time and brake.

David
 

·
Registered
2005 CL65
Joined
·
115 Posts
Yep, broken wires in the loom to the door. Already had to fix mine. Started out as the speakers cutting out when the door was opened. Eventually involved the locks too. I pulled my door panel off disconnected everything, and pulled the entire harness out of the door. Then I replaced the broken and cracked wires.

It can be done by just grabbing the boot, pulling it away from the door, peeling open the looms an putting butt connectors on the broken wires, but only wanted to do it once.
 

·
Registered
my current cars1986 560sec,1994 s500,1995 cl600,1999 clk430,2003 bmw 530I,2001 cl600
Joined
·
73 Posts
does your rear passenger window work?also check to see if both headlights work.
check the fuse link under the passenger front floor carpet.
 
1 - 10 of 10 Posts
Top