Mercedes-Benz Forum banner

Electrical Gremlins

768 Views 7 Replies 6 Participants Last post by  Ears
I am finally finding time to do a few things I want to the newly-acquired 1997 SL500 that I bought a few weeks ago. I have now set my sights on trying to diagnose a few electrical anomalies.

Previous owner added a python remote start/security/remote central lock system. To date, it works perfectly... thankfully! I say "thankfully", because the only two keys I have are the mickey-mouse key, and flat, master key. I did have a non-transponder master cut for doors, etc (I don't have the original fobs).

here's what doesn't work:
1. ASR Off switch- light does not light up in instrument binnacle when pushed. I haven't had time or conditions to test it physically. The ASR light in the binnacle does light up upon key being turned on before starting...
2. Clock- Dead as a Do-Do...
3. Windows don't roll up/down with the master key turned as prescribed... In fact, only the driver door unlocks (central does not work with master key)
4. Little indicator light on the central vent warm air switch does not light up when pushed...
5. Standing lights, neither left nor right side, work when switched.
6. W/S switch... is there any indication other than visually what position the switch is in? Car seems to be starting off in second gear, or it is weaker than I expected on FT launch (my 560SL would leave two beautiful black ribbons if started off briskly in first gear... this car, nada). When I count the shifts, I count 4, but not sure if the last one is the torque converter lock-up. Seems same regardless if W or S. Can't complain about the MPG... Better than 24 on the highway, and the damn thing SCOOTS!
7. The pagoda light (on the folding top control) does not light up when operated. I have replaced the switch because the original one had a loose red "handle", and the bulb underneath was busted.
8. Neither of the vanity mirrors light up (haven't checked for voltage yet...)

I have looked at the fuse chart, checked many fuses (blade-type, not aluminum bullets), and wiggled quite a few more to no avail. Nothing seems common, at this point, except that the Python system has been added. Also, battery is brand new.

Car is 100% usable/enjoyable as is, but I prefer all systems operational.

Anyone care to opine?

Thanks...
See less See more
1 - 2 of 8 Posts
Guys,
Thanks for the opinions and guidance as I navigate the foibles and idiosyncrasies of the 129... I look forward to the journey.

(I tried to reply twice from my phone, but...nada)
1 - 2 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top