Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1981 300D and 1985 280SL Euro
Joined
·
21 Posts
Discussion Starter #1
I drove about 100 miles last week to pick up a friend at the airport, let the car sit 20 minutes, and then wouldn't start when I came out (there was a little battery left, but not enough to crank the starter). I checked and had not left the headlights on. The only unusual phenomenon on the drive down was that the radio, turn signals, heat and other dashboard electrics would turn off intermittently, then come back on. Since then the car has started fine twice, but today I experienced the same symptoms as the airport drive, needing a jump twice. I turned the car off after a 30 minute drive, then immediately tried to restart it, but there was hardly any battery left and it wouldn't start. I suppose the alternator should be suspected, but the car has not overheated and the battery idiot light hasn't come on. The only thing I've done is put in a new battery six weeks ago.

I thought I would solicit your opinions before taking the car for professional attention.

Thanks,

Brian
 

·
Registered
1985 300CD Turbo coupe, 2006 E320 CDI sedan
Joined
·
573 Posts
Thoroughly clean both ends of both battery cables. Clean also the battery posts, and the electrical junction box on the fender right in front of the battery tray. Get everything right down to shiny metal. Reconnect and re-evaluate

//greg//
 

·
Premium Member
Joined
·
496 Posts
See if it's charging. Cheapo multimeters will do the job, and can be purchased at harbor freight, radio shack, or even autozone type stores.

When my alternator has failed (one each in two cars) the radio blinking off and back on was a tell tale sign.

While running, it will be over 13v if it's charging at all. If it's 12.x volts, it's not. Since these cars don't need the electricity to run, it's very easy to make it quite a while driving around without a charging system. My jeep might make it 15 mins without its system charging.

Dave aka Ghan
 

·
Registered
'83 300CD
Joined
·
53 Posts
My alternator died last week, same thing with the dash lights and radio. I was stuck in traffic in the snow we had... I made it 2+ hrs with those symptoms! She got me home (it was a 7 1/2 hour ordeal) but she was dead as a rock the next morning.
 
1 - 4 of 4 Posts
Top