Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
1974 450 SEL Champagne Beige Metallic(Sold); 1986 560 SEL Champagne Metallic
Joined
·
181 Posts
Discussion Starter #1 (Edited)
Red Light!

Good Morning All!

I have a red light :eek: on in my cluster on the far right between SRS and the clock set button. It does not have a graphic, and the owner's manual does not discuss that position in USA cars.

Does anyone have a clue as to what the car is trying to tell me? :confused:

Many Thanks,
Ron
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
O2 Sensor light. Changed out the O2 sensor lately? It is supposed to come on then go out in a few seconds like the rest of the warning lights...unless the sensor or the Cat has a problem.
 

·
Registered
1974 450 SEL Champagne Beige Metallic(Sold); 1986 560 SEL Champagne Metallic
Joined
·
181 Posts
Discussion Starter #3
Thanks Chadahar!

My first post was from my (flawed) memory, instead of getting my lazy butt out and confirming location. The red light in question is the empty space BETWEEN the SRS light and the O2 sensor light. The clock knob is to the right of the O2 sensor light.
 

·
Premium Member
2012 CL550 4MATIC Coupe
Joined
·
9,985 Posts
Well it's not necessarily the O2 sensor, but it is the Emissions system. It means your Emissions computer coded and you need to decode it. It does not mean your engine is going to blow up, just that there is a problem with emissions.
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
Edit:
I actually went out and started both my Gen II cars....no red light came on at that location. They all fired up upon the key being turned, but went out ASAP.

Could that be from an aftermarket alarm system that is now disconnected?

My second thought is below as was posted earlier:

Actually it is the restraint system light. Seat belt light that normally goes out when the belt is fastened. Try cleaning the belt latch with electronic cleaner spray.

Probably the sensor in one of the seat belts is out of whack.
Spilled anything into the seat belt latch? Junk in the latch,(Dirt, dust, bits of whatever). Had the seat out lately, been under there for any reason? You could have unhooked the sensor wire, or cut it or???
How about the seat belt beeper, sometimes, in an attempt to silence that, the sensor gets corrupted.
 

·
Registered
1974 450 SEL Champagne Beige Metallic(Sold); 1986 560 SEL Champagne Metallic
Joined
·
181 Posts
Discussion Starter #6
I thought the seat belt alerts were up in the dome light assembly above the interior rear-view mirror? I'll clean the seat belt buckles, but haven't done any take-outs or other work lately. There is no graphic overlay on the aforementioned red light, just the red glow. All other indicator lights are accounted for in the owner's manual. Could this be some Euro option that a previous owner connected. I have an Alpine siren under the hood and a red LED in the tray next to the fanfare switch, but no other alarm accoutrement. Still a mystery....
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
Is that a Euro CAR?
My Euro 500SEC Gen I has a red light where you talk of as being located and a green one beside it. The Green one is for the O2 sensor that was added when Federalized. And the Red one I have no clue, but it lights and goes out.
I wonder IF your cluster has been out or if a bulb was replaced into the wrong receptacle in the back of the cluster. Some of mine in the Euro car are empty on purpose.
 

·
Registered
1974 450 SEL Champagne Beige Metallic(Sold); 1986 560 SEL Champagne Metallic
Joined
·
181 Posts
Discussion Starter #8
Thanks Chadahar and Mclare, I have not seen this light ever before, so that is why I wonder. My VIN states it is a USA vehicle. I guess I will have to get a schematic and see if I can trace down the offending sensor, relay , code, short, gremlin, et al....

Please let me know if you think of anything else.

Cheers,
Ron
 

·
Registered
'82 Euro 500SEL, '85 Euro 500SEC AMG WB Cabriolet,'86 Euro 500SEC RUF
Joined
·
9,487 Posts
I looked in both my 89 560 SEC and SEl owners manuals and the light you have coming on isn't listed in either(like your manual) I think someone replaced A Check Engine O2 in fed cars, Emissions in a CA car) light bulb into the wrong port(between the check engine light and the SRS.
 

·
Registered
MB 420SEL 1986-Bought in 2010, MERCURY VELLAGER-1995, NISSAN MAXIMA 1996, Buick Lesabre 1995
Joined
·
426 Posts
As Chadahar mentioned. This happened to me while I was replacing the those bulbs. When I pulled the instrument cluster out, I disconnected all the wires from these socket and then I found that there are numbers printed on the wires and also on the sockets for the bulb at the back of the instrument cluster. When put the wires with the bulbs back in the instrument socket a new red light came on when I turn on the ignition key. What I noticed that there is socket # 2 which has no graphic and there is no wire with buld with # 2. So the #2 socket is suppose to empty. So I pulled out the wire # 3 from socket # 2 and put it back in socket # 3. That solve the problem.

So I think MBlov needs to pull out instrument cluster and double check the matching of wire number with socket number on the instrument cluster.

Sahai
 

·
Registered
1974 450 SEL Champagne Beige Metallic(Sold); 1986 560 SEL Champagne Metallic
Joined
·
181 Posts
Discussion Starter #11
Update!

I found that the red light only comes on when the parking or main headlights are on. I thought about an out of place dash illumination light, but the intensity does not change when I adjust the rheostat. I also poured over the wiring diagrams and cannot find any indication as to what this bulb might be. Any further suggestions?

Cheers,
Ron
 
1 - 11 of 11 Posts
Top