Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
2006 C230 139k and 2005 C240 4matic 103k
Joined
·
131 Posts
Discussion Starter #1 (Edited)
My c240 would not pass inspection even after driving the car 1500 miles. 5 Items were NOT READY, the cat, EGR, O2,and two others I forgot. There are NO CODES like p0410 or p0...... on the OBD scanner exceot FOR the 5 items not ready. Also, the motor fan start with when starting the car very loud and does not stop until I turn the car off.
Is there any chance that I need a new ecu and? and if so what are the chances that a used ecu from ebay need to be programmed, and can i get the exact number for ecu which does not need programming?
Thank you
 

·
Registered
Joined
·
272 Posts
An ECU can potentially show false codes. Especially if the main chip inside the ecu is acting up


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
272 Posts
As far as the fan I would get a new thermostat and a new temperature sending unit and potentially you may need a new fan motor or fan assembly when they get loud the bearings inside the fan motor are starting to show their age

I would fix the thermostat and temperature sending unit first with a good cooling system flush and new coolant then rescan for codes


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
272 Posts
I would not get a used ecu unit I would get a remanufactured one but it will need to be programmed to the vehicle


Sent from my iPhone using Tapatalk
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
18,979 Posts
The engine suction fan speed is controlled by the ECU. If it cannot get a signal from the ECU, it will run on high the moment the ignition is switched on. A bad ECU will cause this, but usually the engine won't even run if the ECU has failed. The ECU will run the fan on high speed if it cannot determine the engine or coolant temperature. I suspect that is the problem. You need to get a proper diagnosis using scan tools that can read MBZ proprietary systems.
 

·
Registered
2006 C230 139k and 2005 C240 4matic 103k
Joined
·
131 Posts
Discussion Starter #6 (Edited)
I have replaced the thermostat, the sensor, and the coolant today but the motor fan comes on FAST AND LOUD the minute I start the car. I used the modest OBD I have to scan and got no codes DTC 00 and I/M has 5 NOT READY for cat, evap, O2 Egr and other. I reset everything and I got NA for each one of those. What is going on and do I need to do next??
thanks
 

·
Registered
2006 C230 139k and 2005 C240 4matic 103k
Joined
·
131 Posts
Discussion Starter #7
How do I find out the exact pin that responsible for the motor fan on the ECU because there is a pin that is missing or broke off the ecu?
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
18,979 Posts
One thing to check - has the E-box (which houses the front SAM and ECU) gotten water inside?
 
1 - 8 of 8 Posts
Top