Mercedes-Benz Forum banner

1 - 20 of 20 Posts

·
Registered
05 E55
Joined
·
419 Posts
Discussion Starter #1
Or as our friends from south of the border say, "Bastardo!" lol I love that word..

ANYWAY, my EC Button on my Climate Control refuses to go off....the light just stays on and the AC can't turn on as a result. So, I pulled the fuse to the AC blower fan, cleaned it and stuck it back in.

When I started the car back up, the EC button would now go off, but come back on after a few moments. After several times of hitting it and swearing, it finally stayed off and the AC cooled me down.

But then it happened again after I shut the car off.

WTF is going on? I held down the REST button and it gave me a bunch of codes...what do they mean?
 

·
Registered
Joined
·
215 Posts
Thats something i've had to live with since i got my car. By now, I am just used to reseting the climate control byt turning the ket to position 2 (when all the light on the instrument cluster come on) wit like1.5 secods, then turn the ke to position 0, wait like 1 second, and the turn the car on. Let me know if this works for you.
 

·
Registered
05 E55
Joined
·
419 Posts
Discussion Starter #3
juancpath - 5/9/2005 9:10 AM

Thats something i've had to live with since i got my car. By now, I am just used to reseting the climate control byt turning the ket to position 2 (when all the light on the instrument cluster come on) wit like1.5 secods, then turn the ke to position 0, wait like 1 second, and the turn the car on. Let me know if this works for you.
Thanks man, I'll give that a shot during lunch today. So, 2, then 0, then it should go on, eh? Sounds good.

I wonder if I'm low on freon or someting...I rarely use the AC, but it is a 99 and has never been changed.
 

·
Registered
Joined
·
215 Posts
Actually, I was told that once i re-charged my freeon the EC light would go away... hasnt happened to mine.. Let me know if you get it re-charged and yours goes away.

About the above procedure, once you have turned the car on, the blower/fan must be on before you can turn the ec light off.
 

·
Registered
Joined
·
215 Posts
ThrillKill - 5/9/2005 11:30 AM

Just a wild guess, but check the a/c belt, could be slipping.
Hummm. I am not 100% sure but.. if the EC button is on, the AC compressor will not come on, therefore the belt will not turn at all... OR is it the other way? I'll check my car in my lunch hour.
 

·
Registered
Joined
·
2 Posts
Mine has the same problem. Although I recharged the freeon and the EC light still wouldn't go away. Another way to by pass this is set the driver's temp to LO and passenger to "HIGH" then press EC & Rest buttons at the same time. The light will go away for just that time. I talked to the service advisor and he said it could be either ran out of freeon, leak or the evaporation unit is broken.
 

·
Registered
2001 CLK 55 AMG, 2003 Jeep Liberty Renegade
Joined
·
25 Posts
I just purchased a 2001 CLK 55 AMG with the exact same problem. Checked the freon level, it's right. Checked error codes in the ecu, no errors.

Has anyone actually fixed this problem? Or is everyone just used to quick fixes?
 

·
Registered
01' CLK55 Carlsson RS Lorinser fenders 19" Sevas S-Star - 02' IS300 L-Sportline Body, Exhaust, Susp
Joined
·
55 Posts
I have begun to encounter the same problem at 60K miles. My freon level is correct at 40lbs. I believe there is a faulty a/c component soemwhere. I haven't been able to get any quick fixes to work.....Riding with no a/c for 3 weeks....beginning to get hot...
 

·
Registered
CLK430
Joined
·
2 Posts
ec light stuck on

Hi, I have read some of your responses. I just purchased a clk430 in January and in california, the weather is starting to get warm. Now I am realizing the ec light is stuck on as well and the car will not cool. So...Does anyone know if we can file a complaint somehow with mercedes since this should be a recall issue? Thanks! And hope everyone is staying cool!
 

·
Registered
02 clk55 , 01 e430 4matic
Joined
·
41 Posts
Hey guys this is not a problem caused by the belt or anything else of that mater , It means you are out of A/C refrigerent there fore it will not engage the clutch on the compressor go get a evac and recharge and some dye and see where your leak is mine was my reciever drier

If your level is fine then it is the level valve on the reciever drier this is known to go as well as the Fan switch on the reciever drier
 

·
Registered
CLK430
Joined
·
2 Posts
thank you. i will have it checked out. so, i do not need a new climate control panel I guess......That is what someone at mercedes dealership suggested for $600!!! Thanks again.
 

·
Registered
1965 Peel Trident, 1972 chevy vega
Joined
·
459 Posts
Last summer my A/C went out. The compressor would not engauge, this was a big problem cause it was like 108 outside, and since i have black interior if i put the top down i would fry, so i decided to bake and put the windows down. It was a pretty costly repair. They replaced the compressor. They said that because the A/C isnt used in the winter, and i dont have a heated garage it can get messed up.
Good Luck
Tyler
 

·
Registered
1998 SL500 Sport
Joined
·
3 Posts
I just got this same problem on my SL500 1998 R129. I have some additional issues that appeared at the same time. Power seats don't work, mirrors don't work, steering wheel positioning doesn't work and windows don't work. I found additional quirks. After turning the car off and opening the door (keep the door open), the seats, mirror and steering wheel positioning worked via the memory button. I also found that with the car running, pressing and holding down the EC button for 10 to 20 seconds cause the EC light to go out and the AC began working again. There was also an issue with the remote lock and unlock. the system would not lock the car.
So far the holding of the EC button down for an extended time seems to be the best work around. It's just a pain needing to do it every time you get in the car. Not having the memory function on the seats working is also a real pain. I use that to get in and out of the car without feeling like I'm auditioning for the circus side show.

So far i haven't read any solid fixes yet. I will keep monitoring the post and researching on my own.

Bob K.
 

·
Registered
92 190e 2.6 Sportline, 2005 clk55
Joined
·
1,197 Posts
I just got this same problem on my SL500 1998 R129. I have some additional issues that appeared at the same time. Power seats don't work, mirrors don't work, steering wheel positioning doesn't work and windows don't work. I found additional quirks. After turning the car off and opening the door (keep the door open), the seats, mirror and steering wheel positioning worked via the memory button. I also found that with the car running, pressing and holding down the EC button for 10 to 20 seconds cause the EC light to go out and the AC began working again. There was also an issue with the remote lock and unlock. the system would not lock the car.
So far the holding of the EC button down for an extended time seems to be the best work around. It's just a pain needing to do it every time you get in the car. Not having the memory function on the seats working is also a real pain. I use that to get in and out of the car without feeling like I'm auditioning for the circus side show.

So far i haven't read any solid fixes yet. I will keep monitoring the post and researching on my own.

Bob K.
Hi Bob and welcome to the site. you may have better luck posting in the SL section. this is the CLK section.
 

·
Registered
Joined
·
2 Posts
00 s class same problemo mate

Or as our friends from south of the border say, "Bastardo!" lol I love that word..

ANYWAY, my EC Button on my Climate Control refuses to go off....the light just stays on and the AC can't turn on as a result. So, I pulled the fuse to the AC blower fan, cleaned it and stuck it back in.

When I started the car back up, the EC button would now go off, but come back on after a few moments. After several times of hitting it and swearing, it finally stayed off and the AC cooled me down.

But then it happened again after I shut the car off.

WTF is going on? I held down the REST button and it gave me a bunch of codes...what do they mean?
Hello Mate. I have the same problem is there a ac relay for the cmpressor?? can anyone help r shed some light on the subject????? freon is good just the light stayng on .so the the compressor wont kick in, cheers paul
 

·
Registered
1998 SL500 Sport
Joined
·
3 Posts
This is the reset procedure for 1998 SL500. it worked on my 1998 SL500 after i recharged the AC unit.
Preparations for DTC Readout
1. Review 11, 12, 14, 15, 20, 21, 22, 31, 31, 41
2. Ignition: ON
3. Temperature selector "LO"
4. Within 20 seconds press REST and Defroster simultaneously for more than 5 seconds.
5. The LED in Recirculated Air flashes and the display shows "d1A".
6. Press AUTO repeatedly until all DTC's are displayed. Record each DTC as it is displayed. The current faults (refer to table) are displayed first, next, the intermittent failures (e.g. 45 °5) are displayed in the display window next to the FAN symbol. END will appear after the last DTC is displayed. Press AUTO again, dEL (delete, erase) will be displayed.
7. To erase: Press Up and Down buttons simultaneously for more than 5 seconds and the display shows: "-- -". To cancel erase: By pressing AUTO button, the current faults will appear again.
8. Turn ignition OFF, to end test.


Bob
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
The EC light for all models comes on when the pressure in the system is low, re charging the system normally works but a faulty pressure sensor on the dryer is also common.
 

·
Registered
2000 CLK 430 cabriolet
Joined
·
24 Posts
Don't know if this will help you, but once you get the EC light issue due to some fault in the system, you have an error code. Even once you re-charge system and solve the problem, if you don't clear the code then the ec lght will continue to come on and your compressor won't run. There are instructions on this sight on clearing the codes. I had this same problem from low refrigerant. after recharging, EC light still would come on. Once I cleared the codes, the problem with EC light was solved.
 
1 - 20 of 20 Posts
Top