Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 1998 E55 AMG has developed what could be a major problem, the cruise control and speed limiter recently stopped working after about a journey of 1 hour, but would reset by stopping the car and restarting the engine. Last weekend the BAS failed followed by the ESP the the anti lock brake warning came on. The speedo failed at the same time as the BAS which means the car won't change gear even on the manual selector. Switching off and back on again the electronics reset, but only for a short period, occasionally when it reset the warning triangle will light up and try an apply the brakes like the ABS is working and if it doesn't applying the brakes a flutter can be felt through the break peddle before everything fails again. The engine runs fine and occassionally the speedo works for long periods but I did notice a slight hesitation immediately before the speedo failed. The last time the BAS failed which was about 7 years ago I replaced the battery. The battery was Professionally tested which indicated it needed charged I have tested it myself it seems ok but it reads 12.35v when static, 12.03v with the ignition on and 14.28v with the engine running. The BAS/ESP/ABS don't indicated failed until the engine has started. Any suggestions
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Found the speed sensor ring on the right hand drive shaft broken, mercedes charge £1100 for an new drive shaft but came up with a supplier of Replacement rings for £45 each, so not quite so terminal!!
 

·
Registered
2001 C240
Joined
·
1 Posts
Found the speed sensor ring on the right hand drive shaft broken, mercedes charge £1100 for an new drive shaft but came up with a supplier of Replacement rings for £45 each, so not quite so terminal!!

Does this fix the problems?
 
1 - 3 of 3 Posts
Top