Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
E350CGI M2010
Joined
·
6 Posts
Discussion Starter #1
Hi all

I have an issue with my 2010 E350CGI that comes and goes. While driving at normal swedish high way speed 110km/h with around 1800rpm I sometimes notice rapid fluctuation in the rpm between 1800 and 2000 rpm and you really can feel this driving.
I have discussed this with a couple of dealears but have got different answers. They also run diagnostics with clean results
Is this something related to the 7G gearbox or can it be something else?
 

·
Registered
2012 E200 CGI / 2011 SPRINTER 316CDI RV/ 2014 SMART 451 CABRIO
Joined
·
32 Posts
Could be the 7g box swopping from 6 to 7 and back again. Are you running in E or S mode. Does it vary if you run in 6 using manual control?
 

·
Registered
2001 SLK320 ex Japan.
Joined
·
261 Posts
Try an ECU reset. I found it to be miraculous.
Put the key in the ignition just short of the start position with the door closed.
Put the accelerator to the floor and hold it there for 5-10 seconds. Before releasing it turn the key off.
After turning the key off wait 2-3 minutes before opening the door otherwise the reset will be interrupted. The dash lights will go off during this period.
This might not be the source of your problem but it's a zero cost trail worth 5 minutes to check.
Good luck!
 

·
Registered
E350CGI M2010
Joined
·
6 Posts
Discussion Starter #4
The problem is there regardless if I'm in E or S mode or in manual control. Also not dependent on if Distronic Plus is activated or not. The strange thing is that the problem comes and goes, it appears for a number of days and then goes away for days or weeks.
 

·
Premium Member
1998 E320 sedan
Joined
·
450 Posts
I would read the OP this way: engine load changes, peddle position constant, RPM fluctuate, torque change is noticed.

If that is correct, then you might have, overheated ATF, not likely
You might be low on oil?
You might have a sticky or malfunctioning solenoid?

What are the set conditions you can add to the OP?
Patch
 

·
Registered
E350CGI M2010
Joined
·
6 Posts
Discussion Starter #7
I haven't tested to reset the ECU yet. That will only affect the gearbox I hope.

Engine load constant, peddel position constant -> rapid rpm and torque change.
Oil level is ok. What is ATF and any specific solenoide?

I will try to share a movie link showing the rpm later.
 

·
Premium Member
07 E350, 80 240D 4 speed, 90 300SE, 87 260E
Joined
·
2,823 Posts
I get this now and then on one of my diesels (not W212). I am pretty sure the source of the problem is an air leak (air getting in) at the diesel injection pump.
 

·
Registered
E350CGI M2010
Joined
·
6 Posts
Discussion Starter #12
If you mean manually changing down a gear or two yes I have tried that but no change.
For now the issue is gone.
 

·
Premium Member
1998 E320 sedan
Joined
·
450 Posts
There are a couple of things that come to mind; 1st thing the dealer should take the car for a test drive while plugged into hand scanner so they can read the live data.
One could assume lockup slip, also valve body pressure control, a week or failing solenoid, who knows which it is?
I have red that the G7 has problem with the valve body and conductor plate.
I would think testing it in real conditions is the proper way to proceed!

ATF is automatic transmission fluid are you sure you have checked the level?

have you read: http://www.benzworld.org/forums/w221-s-class/1609637-722-9-transmission-problems.html

and: http://www.excelmotorworks.com/transmissions.html
Patch
 

·
Registered
2001 SLK320 ex Japan.
Joined
·
261 Posts
Patch's comment brought to mind, did you recently have the Trans serviced by someone other than a dealer or have you or anyone added ATF recently?
My mind is asking did the correct fluid get used if you did.
 

·
Registered
E350CGI M2010
Joined
·
6 Posts
Discussion Starter #15
Thanks for all info.
I will check the level for the transmission oil. The car has always been on service at certified MB dealer according to the service scedule.
 

·
Registered
Joined
·
1 Posts
Hi all

I have an issue with my 2010 E350CGI that comes and goes. While driving at normal swedish high way speed 110km/h with around 1800rpm I sometimes notice rapid fluctuation in the rpm between 1800 and 2000 rpm and you really can feel this driving.
I have discussed this with a couple of dealears but have got different answers. They also run diagnostics with clean results
Is this something related to the 7G gearbox or can it be something else?
I just bought a 2010 E350CGI which is doing the same. Cruising between 100-130 km/h RPM fluctuates by 200 rpm intermittently. You can really feel the car surging when the RPM jumps. I took it to the dealer but they are just guessing...could be the high pressure fuel pump or the torque converter clutch engage/disengage. Did you find out what the problem was on your car?
 
1 - 16 of 16 Posts
Top