Mercedes-Benz Forum banner

21 - 25 of 25 Posts

·
Registered
2006 cdi, 1993 500e
Joined
·
192 Posts
Yea, I was going to say- most of the aftermarket mounts are not filled... and can vibrate. Note that the Lemforder p/n's in the aftermarket won't align perfectly with the current mb #s.
 

·
Registered
2006 E320 CDI
Joined
·
24 Posts
I can also confirm that cheap aftermarket parts are not worth it.
I also bought a set of engine mounts that claimed to be hydraulic, but caused a lot of vibration. After replacing the new cheap mounts with OEM/Lemforder mounts the vibration went away.
Also had issues with cheap driveshaft bearings making noise from rockauto - made by "Anchor". I will never buy that brand again.
It's 'unfortunately' necessary to get quality (more expensive) replacement parts.
 

·
Registered
2005 E320 CDI *black on black with nearly every option*
Joined
·
949 Posts
Also remember, there ARE reputable aftermarket brands. Moog, Mahle, Corteco are all high quality aftermarket brands. I've gone with 100% Corteco for all drivetrain mounts, and there's 0 Vibration transfered to the cabin.

Sent from my SM-N950U using Tapatalk
 

·
Registered
2006 cdi, 1993 500e
Joined
·
192 Posts
I generally try to stay with the OE supplier. Conductor plate I installed last weekend said made in germany and had the MB part number ground off. For all the fuse, manytimes I just buy MB if it's any were close in price.
 

·
Registered
2006 cdi, 1993 500e
Joined
·
192 Posts
FYI,

My Lemforder mounts started leaking and the trans mount failed this past week. 2 years old... 30,000 miles approximately.
 
21 - 25 of 25 Posts
Top