Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys,

this car is a freind's but he somehow stalled it and its been standing since. According to him it overheated slightly, cut off then never started again.

Its a 1995 E300D with 100,000 miles on it. He's not very technical in cars or anything for that matter, he asked me to help him out.

Car had zero fuel when it came to my house, where i put 6 gallons of diesel in it, a new MB battery. - (the mono valve plastic fitment nipple is broken off <- which I believe was the cause for overheating).

when I poured fuel into it, cranked it (it refuses to crank sometimes) and sometimes it just quits while cranking (odd because its not the starter hold feature like a W210).

When I remove the fuel line to the prefilter its empty. Ive put a new O ring on it, filled the pre and main fuel filters - engine cranked tried to start but no game. check pre filter again and it was empty.

Any help on why the starter quits like that. Meanwhile Im hunting around for where to buy Viton O rings from - more specifically what sizes do I need?
 

·
Registered
Joined
·
26 Posts
Hi guys,

this car is a freind's but he somehow stalled it and its been standing since. According to him it overheated slightly, cut off then never started again.

Its a 1995 E300D with 100,000 miles on it. He's not very technical in cars or anything for that matter, he asked me to help him out.

Car had zero fuel when it came to my house, where i put 6 gallons of diesel in it, a new MB battery. - (the mono valve plastic fitment nipple is broken off <- which I believe was the cause for overheating).

when I poured fuel into it, cranked it (it refuses to crank sometimes) and sometimes it just quits while cranking (odd because its not the starter hold feature like a W210).

When I remove the fuel line to the prefilter its empty. Ive put a new O ring on it, filled the pre and main fuel filters - engine cranked tried to start but no game. check pre filter again and it was empty.

Any help on why the starter quits like that. Meanwhile Im hunting around for where to buy Viton O rings from - more specifically what sizes do I need?
you seem to have some electric gremmlins, on top of fuel issues.

the wiring harness on this model is bad very bad, insulation crumbeling especially in hot climate. mine is bad too, but the cranking still works so far on mine.

i had issues with leaking lines as well, do a search there are places which sell all viton o rings all as a package.

one thing which would also work is installing a electric boost pump, a walbro frb5 is the best, around 120 bucks putting out about 10 psi.

then the old o rings might still be usable as long they dont leak fuel. the new ul 2 fuel is what did them in.
 
1 - 2 of 2 Posts
Top