Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi!

First of all it's a great forum, good to see so much info in one place:)

Maybe you could help me with a bit of advice, I ran into some problems with my E270 CDI (2001)...

I had a problem with the shifter box getting blocked in Park position. I put a pencil in the shifter box to unblock gear switching and drove the car home. However there was a grinding/screeching noise from behind-below (transmission?) when switching gears from D to R (and vice versa).

I took the shifter box out (thanks to the detailed guide here), cleaned it but it still won't let me switch. I needed the car badly, so I just completely removed the part which blocks the gear shifter (the multi-angled thing with 4 prongs). So now the box lets me switch gears anytime.

I then assembled the box without that part and the car was running just fine. Until I decided that I needed to put all the "interface" back in (yeah, I drove with all panels removed for a few days). And I switched gears while the car wasn't running, so I could fit that cigarette lighter panel in. Now when I switch from D to R I get this same grinding/screeching sound. And it obviously doesn't sound healthy at all...

So do you guys know if it's related to the shifter box (because while I had the thing half-assembled for a few days, the car didn't make that noise while shifting from D to R) or could something else have broken in the meantime?

Also does that blocking part in the shifter box have any other function other than restricting gear shifting to certain conditions? (i.e. brake pedal held down)

And another question: when I use the brakes and the car comes to full stop, it jerks a little. Kind of like if you brake at high speed and the weight of the car would go forward and then jerk backwards as it goes into a balanced position. Except it happens at any speed, even if I'm driving very slowly. Is that something related to the transmission? I had this jerking thing before my shifter box broke, so it's probably not related to that.
 

·
Registered
Joined
·
35,773 Posts
You have the engine in W210 that is very rare, but your problem is the transmission.
The transmission is electronically engaged and the only mechanical connection between the shifter and transmission is parking lever.
So my first guess is that you misadjusted the shifter and parking brake is catching when the transmission goes into the gear.
If you can't figure it out, that might be a good moment to visit competent shop.
Good luck and welcome to the forum.
 
1 - 2 of 2 Posts
Top