Mercedes-Benz Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello All,

Perhaps someone could kindly point me into the right direction - I currently suspect best way is to start with replacing the thermostat and if that does not solve the issue, perhaps radiator.. but here is the short of it.

So I am in Australia, today was reasonably warm day, about 35 degC. Drove small errands in the morning - nothing of note. The we set off on a 500km journey at around 11am only to notice that once I entered motorway ramp and hit 100km suddenly for about 30sec air conditioner started blowing warm air - I glanced at the temp gauge and to my horror it was around 100 degC. It was clear we won't make our journey so I pulled off the motorway into the nearest car parking spot.

Some previous history - about a year ago, "Top up Coolant" message appeared, it was diagnosed as water pump failure. Water pump was replaced. Then message started re-appearing. Attempts at finding a leak brought no luck. Message kept appearing say once a month. I kept topping up with distilled water or coolant. December I had a pressure test done on coolant system and there was a tiny leak towards the radiator front... garage was not super keen on taking bits apart and fixing it, so agreed to fix a bit later. Oddly, message never came back again to this date. All of this could be a complere red herring.

So going back to today. Parked up, I opened the bonnet and slowly unscrewed the coolant tank to see what was going on. Pressure released but coolant was boiling over - so a fair bit came out... had to wait for 20min to unscrew fully without any further spillage. Strangely level seemed okey - but of course it was hot. Topped it up a tiny bit with water. Managed to get back to my garage.. uphill or anything over 60km temperature gauge went straight into 100s degC and above. Once at home, I did check AC off, AC on, fans were coming on/off. Obviously the car was trying to aggressively cool itself down... but overall I am very surprised by the very sudden onslaught of whatever this might be. I guess my plan is to replace thermostat (cheapest option) and see if that will fix the issue. Next step would be presumably the radiator? Can it be flushed or is it a one off consumable part? Any other suggestions? I haven't checked the fully cooled down coolant level - will do tomorrow morning after overnight cooling.

Cheers, Mike
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,259 Posts
Welcome to the forum @payingaustralia - please take a moment to read the information on the link below. It explains how to update your user profile so that your car's details and your location appear on each post below your avatar. This is good information for others to know when trying to help. It also has good information about how the forums are organized and how to use the search feature:

Find your Forum Section, Navigate & Search

Have you tried pulling codes?
 
1 - 2 of 2 Posts
Top