Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Mercedes E200 Auto w210
Joined
·
7 Posts
Discussion Starter #1
Hi guys! Really love this site, its helped me alot with my car, with different kinds of issues. I've got a Mercedes E200 automatic -98 with around 160000 km on it, German specs and I really love it!

Things that I've changed:

New MAF
New Co2 sensor
New front flex disc
New ATF oil with filter for the gearbox
changed the oil in the diff, with the oil seals

I changed all of these things recently, and I bought all of the parts from Mercedes.

Last year,

All the brake pads, and brake discs
new spark plug
engine filter

I've spent alot of money on this car and im planning of having this car for a long time.

The Issue with the car is when the gearbox is in fourth or fifth gear, and there is a red light, or that i have to stop it downshifts kinda hard to third gear, I've had this issue for some time now and its getting annoying, i've had it to a couple of shops but they dont know what it is, or they just say that its normal or sometimes that they even dont feel the hard downshift. if i let the car roll and dont press the break, i dont feel it that much, sometimes never at all, and when i press the breaks a little bit harder it sometimes clunks, downshifts hard. When it upshifts it changes very smooth, very smooth indeed. but its just from 4-3 gear that it happens. And one more thing, sometimes it shifts very nice from 4-3, SOMETIMES ONLY.

I hope you guys can help me with this, recently repainted the whole car, because of rust as well :p there's salt everywhere here in Sweden at winters.

Really would really appreciate some help with this! Thank you.
 

·
Registered
Mercedes E200 Auto w210
Joined
·
7 Posts
Discussion Starter #3
So, i changed the breakbooster today and the car runs GREAT! had a small vacuum leak in it near the brake pedal.
 
1 - 3 of 3 Posts
Top