Mercedes-Benz Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
918 Posts
Discussion Starter #1
I'm currently in the process of refinishing the air filter housing. The car must be driven tomorrow but the housing won't be ready by then. Is it safe to operate the car for 1 day without the air filter in place? The U tube is still attached to the turbo. Thanks.
 

·
Registered
Joined
·
918 Posts
Discussion Starter #3
Yea, I figured since the opening is now facing the opposite way bugs won't be flying into it. And its not like it'll be driven offroad or anything.
 

·
Registered
1983 300D Turbo Diesel
Joined
·
1,799 Posts
I know this sounds like a dumb idea but temporarily can you secure a piece of pantyhose or sock over the opening? Will that help at all?
 

·
Registered
Joined
·
918 Posts
Discussion Starter #5
I think that would get sucked in, lol. I've decided to wait for painting the other side until tomorrow and hope that the first side is dry enough by the morning to install again. I'll post some before and after pics when its all done.
 

·
Registered
1983 300D Turbo Diesel
Joined
·
1,799 Posts
I meant like stretch the pantyhose or sock over the open hole on the outside of it and secure it with a rubberband or a ziptie?
 

·
Registered
Joined
·
918 Posts
Discussion Starter #7
Perhaps, but having to repaint the housing is a lot cheap than a new turbo and/or engine.
 

·
Registered
1982 Mercedes Benz 300D Dark Blue
Joined
·
41 Posts
i say go for it !! that is , if you will not encounter any dirt, dust, sand, rain, snow, trash, well lets just say all you need is clean unobstructed fresh from mother nature all natural air. you should have no problems ,,LOL:surrender:
 

·
Registered
'77 6.9, 74 240D, 96 Ram 5.9L Cummins
Joined
·
2,654 Posts
I would ask for a ride.

Anyone remember when Karugs's burgundy wagon sucked in the U tube O ring?! :eek:
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
I would ask for a ride.

Anyone remember when Karugs's burgundy wagon sucked in the U tube O ring?! :eek:
Yes, it happened. The O ring was gone and the impellers had chunks missing. Had a nice big cloud of smoke at the back and a bit of loss in power...:eek::mad:

So next time you install the U tube, make sure it's already attached to the air cleaner housing before you reinstall it. Then tighten the clamp at the turbo inlet.
 

·
Registered
Joined
·
918 Posts
Discussion Starter #17
Yea...it was kind of an impulse repair. It was bugging me for awhile and I had just bought all the supplies I needed for another project so I figured what the hell.
 

·
Registered
Joined
·
507 Posts
No air filter is a bad idea. There are any number of stupid things that could find their way into those close-tolerance, very expensive parts beyond the intake. You'd probably be better off just buying another MB for the day! :D
 
1 - 18 of 18 Posts
Top