Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
-1985 300d (champagne/palomino 133k) -1979 300d (dead parts car)
Joined
·
128 Posts
Discussion Starter #1
so, yesterday i went for a lil drive in the 85 300d. when i went to buckle up, the seat belt caught as i pulled it halfway across myself. now, it won't retract, and it won't pull out at all. this happened once before, but fixed itself after about 5 minutes. anyone had this happen? how to fix, please?! tia
 

·
Premium Member
Joined
·
496 Posts
I've not suffered it myself in the mercs yet, but I know my Jeep has it happen all the time. I'm sure it might have something to do with the sinking it in mud... ;)

As for what to do -- fiddle with it, or replace it. It's a matter of the locking mechanism being stuck. If you feed it in, just a little bit manually, then attempt to withdraw it again, over and over, it can get'em to work again.

If it continues to be annoying, junkyard time! Make sure to bring a potato chip clip, or some tape to stop it from retracting all the way when you undo it, otherwise it can be a HUGE pain to get to release!

Dave aka Ghan
 

·
Registered
-1985 300d (champagne/palomino 133k) -1979 300d (dead parts car)
Joined
·
128 Posts
Discussion Starter #4
thanks for the reply, dave. i have fiddled all i can with it to no end. thanks for the chip clip tip! luckily i have a parts car, as i havent seen a w123 in a JY around here since the 90s...
 

·
Registered
1985 300D, 1991 190E 2.3, 2002 Winnebago Rialta, 2010 Volvo V70
Joined
·
35 Posts
I have had this happen in my '85 several times, typically in the morning when I first start the car. Feeding the belt into the B-pillar, even though it is not retracting, usually does the trick for me. As I feed the belt it, it will eventually click, and then retract.
 

·
Registered
-1985 300d (champagne/palomino 133k) -1979 300d (dead parts car)
Joined
·
128 Posts
Discussion Starter #6
i have tried that many times. just wont go. maybe because it has been below freezing temps here for about a week. but i did get Goldie to start up the other night in 9F temp without being plugged in! that's a win in my book!
 

·
Registered
1985 300D, 1991 190E 2.3, 2002 Winnebago Rialta, 2010 Volvo V70
Joined
·
35 Posts
i have tried that many times. just wont go. maybe because it has been below freezing temps here for about a week. but i did get Goldie to start up the other night in 9F temp without being plugged in! that's a win in my book!
Mine usually sticks when it is cold (though cold in Southern California is relative). I think '85 was the first year for the emergency tensioning retracting seatbelts. Maybe that has something to do with it?
 

·
Premium Member
107, 115, 116, 123, 124, 126
Joined
·
5,924 Posts
I had that happen with my 107 and it turns out the plastic gear inside the retractor broke, so I had to replace the whole thing. Hope it's not that, but it could be.
 

·
Registered
1985 300TDT
Joined
·
4 Posts
same prob

I am having the same problem. I am also just getting started with this car. Two questions. Best manual to guide me through an attempt to repair myself? Best way to find a used replacement? New part is $300 or more.
 
1 - 10 of 10 Posts
Top