Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
2003 E500
Joined
·
55 Posts
Discussion Starter #1
Hey guys,

a couple of weeks ago, a malfunction message showed up on my dash saying that my driver side mirror light is out, but it wasn't, by the time I got home, the message disappeared and never came back on again.

Tonight, after I washed and waxed my car, the driver side mirror light DID go out and the message appeared again, but this time the light doesn't work anymore, and now im home, and it's still not working.

Any ideas? Maybe a fuse? what should I check first?

Thanks guys, appreciate it!
 

·
Super Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,135 Posts
Can you fill out your UserCP with year and exact model? The mirrors changed after 05 or 06.
 

·
Super Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,135 Posts
Okay, the mirror pivots back towards the glass on the door.
A helper is handy for this. With the mirror in that position
you will see a shiny stainless release tab. Press on that with
a flat head screw driver. The cover with the blinker slides right off.
It sounds like your has failed or the connection is bad. The connection
is made when the mirror cover slides back on. Inspect the connection
and the blinker piece itself. If it needs to be replaced it is not a very
costly item.
There are videos on You Tube and some pictorial steps on the interweb. :)
 

·
Registered
2003 E500
Joined
·
55 Posts
Discussion Starter #5
So I might need a new cover? Interesting, well great I'll look at it tomorrow and i'll report what I find. I really hope it's something minor...

Thanks Noodles!
 

·
Super Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,135 Posts
Not the covering. Just the blinker strip. They are two separate parts. The blinker strip
is just attached to the cover and that is the easiest way to get to it.
 

·
Registered
2003 E500
Joined
·
55 Posts
Discussion Starter #7
So what happened was that it was loose, so the plug wasn't making a good connection. Pushed it in and now it's working. You're awesome!

Thank you!
 
1 - 7 of 7 Posts
Top