Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a 96 S420 and finally got around to trying to figure out my driver door unlock problem (with the key it wont do anything in driver door), so I finally got panel off and now I can hear a hissing sound when the unlock is supposed to happen, does that mean a leak? are the 2 little plastic hoses the vacuum lines?

I guess I need to feel around and see if I feel the leak?

any ideas/suggestions?

also what do i look for since the key doesnt do anything in the door? It does what its supposed to do when i do it from the trunk.

thanks for any help!

Brian
 

·
Outstanding Contributor Always Remembered RIP
Joined
·
6,543 Posts
The vacuum element has split inside, they just clip onto the actual lock, I have just got one fro my trunk lock,only £13 in the UK.

i you have the close assist the will be 2 actuators, you only need the locking one. you need to change it as soon as possible or the PSE pump will burn out if it runs for the max time
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
you were right...

The actuator did split...i was able to fix it though..all back up and running!

i was also able to take the door handle off and fix the key issue...the pin was not attached to the handle anymore so i connected them back and all good....now if i can just find a passenger mirror i would be golden!

thanks,
 

·
Outstanding Contributor Always Remembered RIP
Joined
·
6,543 Posts
The actuator did split...i was able to fix it though..all back up and running!

i was also able to take the door handle off and fix the key issue...the pin was not attached to the handle anymore so i connected them back and all good....now if i can just find a passenger mirror i would be golden!

thanks,
Loads of them over here, but the wrong side for me in the UK, I need one as well, as they are on opposite sides we will have to do a swap
 

·
Registered
Joined
·
680 Posts
Hi bdepew, you look pretty new! Welcome.

Depending on what is wrong with your pax mirror, and your car is Left-Hand-Drive, I might be able to help.

Our car is a '97-S320. I have a used but fully functioning (don't know if it's original) right-side pax-side mirror, but inside parts and heated-mirror only, which includes the very-worn triangular rubber gasket that goes between the door and the mirror. Only the gasket was going bad, but I couldn't find one, and it didn't need a new cover, so the smallest "piece" I could buy that included the gasket was an almost-complete mirror -- no new cover. This also has the motor for folding flush. The wires are very good (left ones weren't). It does NOT have auto-dimming. I don't think any pax mirrors have heating AND auto-dimming, nor auto-dim only. It's nice to have one mirror that doesn't dim. In case yours does have that, the 2 variations ("heated" -vs- "heated and auto-dim") have different connectors, so you would lose both functions using mine.

Most of my left one's wires had cracked insulation and green-powder on the exposed wires (and a severely dark mirror due to bad auto-dim fluid). Sometimes movement was erratic, and memory function was iffy. I read this could be due to bad insulation, even on newer 140 models, and fortunately hadn't seen any smoke yet, as others have reported. Initially I put some "Liquid Insulation" on them, and it worked perfectly. After approx 6 mo., I had the money to buy the inside-only parts for both sides...all to get a good rubber gasket. About a month ago one guy was seeing if he could get just a new gasket -- I'll check for that. A couple of connectors hide behind the gasket even when the mirror is folded back, so the gasket protects those from rain/snow/dust/dirt, but alas, not the inside parts. The motors are sealed fairly well anyway. But if you don't have to, I'd suggest only folding them back on a non-rainy/snowy day. They can be stolen easily if they're folded back, too -- only 3 screws and pull apart 2 connectors.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
so....

Hi bdepew, you look pretty new! Welcome.

Depending on what is wrong with your pax mirror, and your car is Left-Hand-Drive, I might be able to help.

Our car is a '97-S320. I have a used but fully functioning (don't know if it's original) right-side pax-side mirror, but inside parts and heated-mirror only, which includes the very-worn triangular rubber gasket that goes between the door and the mirror. Only the gasket was going bad, but I couldn't find one, and it didn't need a new cover, so the smallest "piece" I could buy that included the gasket was an almost-complete mirror -- no new cover. This also has the motor for folding flush. The wires are very good (left ones weren't). It does NOT have auto-dimming. I don't think any pax mirrors have heating AND auto-dimming, nor auto-dim only. It's nice to have one mirror that doesn't dim. In case yours does have that, the 2 variations ("heated" -vs- "heated and auto-dim") have different connectors, so you would lose both functions using mine.

Most of my left one's wires had cracked insulation and green-powder on the exposed wires (and a severely dark mirror due to bad auto-dim fluid). Sometimes movement was erratic, and memory function was iffy. I read this could be due to bad insulation, even on newer 140 models, and fortunately hadn't seen any smoke yet, as others have reported. Initially I put some "Liquid Insulation" on them, and it worked perfectly. After approx 6 mo., I had the money to buy the inside-only parts for both sides...all to get a good rubber gasket. About a month ago one guy was seeing if he could get just a new gasket -- I'll check for that. A couple of connectors hide behind the gasket even when the mirror is folded back, so the gasket protects those from rain/snow/dust/dirt, but alas, not the inside parts. The motors are sealed fairly well anyway. But if you don't have to, I'd suggest only folding them back on a non-rainy/snowy day. They can be stolen easily if they're folded back, too -- only 3 screws and pull apart 2 connectors.
So were you saying you had a passenger side mirror? folding?

$$ ?
 

·
Registered
Joined
·
1,169 Posts
Hello! I am having i think the same problem as you. I can lock but not unlock the driver door when i press on my key pad. All the other doors lock/unlock with out a problem. All of my closing assist works on all doors. I do notice a hissss whenever i sit down on the driver seat and sometimes my trunk will open if i sit too hard. At first i thought it might be the lumbar bag but the bag is fine. The only thing i can think of is the lock actuator. So i looked on ebay for a vacuum door lock actuator and this is what i found.

Vacuum Actuator Door Lock Left Front S500 Mercedes Benz W140 Used Part | eBay

Would this be the correct part to replace?
 
1 - 7 of 7 Posts
Top