Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
W163 2005 ML350, S124 1994 E220
Joined
·
68 Posts
Discussion Starter #1
Hi

A few days ago my battery died and i was locked out from the car. So i thought i could use the key in the keyhole. But nope. Its just spinning around. Nothing happening. And when i got the car unlocked (Got it charged and used controller) i tried once more but still couldn't use the key. Even tried the spare key still same. Tried to see if it was the cold weather but still the same.

Ive read somewhere that this is a usual problem with the early w163 but this is a 2005 ml350 so yeah.


Anyone have any suggestions what might be the problem or have a solution?
 

·
Registered
W163 2005 ML350, S124 1994 E220
Joined
·
68 Posts
Discussion Starter #2
One more thing. Every time i use left indicator high beams flashes for 1 sec and then goes back to normal. Is this normal or some kind of wiring issue? old owner mounted bi-xenon in high beam.
 

·
Registered
Dallas, Texas
Joined
·
7,377 Posts
Hi

A few days ago my battery died and i was locked out from the car. So i thought i could use the key in the keyhole. But nope. Its just spinning around. Nothing happening. And when i got the car unlocked (Got it charged and used controller) i tried once more but still couldn't use the key. Even tried the spare key still same. Tried to see if it was the cold weather but still the same.

Ive read somewhere that this is a usual problem with the early w163 but this is a 2005 ml350 so yeah.


Anyone have any suggestions what might be the problem or have a solution?
Most likely pin that engages door latch broke.

 

·
Registered
W163 2005 ML350, S124 1994 E220
Joined
·
68 Posts
Discussion Starter #4
Hmm seems like its going to be expensive to fix. Will call my dealer and see what they can do. On the second thing you dont know?
 

·
Registered
Dallas, Texas
Joined
·
7,377 Posts
One more thing. Every time i use left indicator high beams flashes for 1 sec and then goes back to normal. Is this normal or some kind of wiring issue? old owner mounted bi-xenon in high beam.
It is not normal. Wiring inside headlight got butchered.
 

·
Registered
W163 2005 ML350, S124 1994 E220
Joined
·
68 Posts
Discussion Starter #6
So i would check wiring to left front headlight and rear?.


Looked at the price for a new key cylinder they want 250£ for it. Seems like expensive. so im going to chill and remove it and verify the problem first!
 

·
Registered
1989 W124 260E
Joined
·
1,530 Posts
Mattias Best to pull the door card and find the lock part that broken . But it coild be a simple fix,, who knows till you inspect it .Have you a manual for your W124
 

·
Registered
W163 2005 ML350, S124 1994 E220
Joined
·
68 Posts
Discussion Starter #8
The S124 is a manuel and and A124 is automatic.

Im gonna see if i can remove door lock cylinder from the outside.
 

·
Registered
W163 2005 ML350, S124 1994 E220
Joined
·
68 Posts
Discussion Starter #9
Just realised that u meant manual and not what tranmission i got. :D
I think i have a book.
 

·
Outstanding Contributor
2002 ML320, 2003 A160, 2002 ML500, 2018 GLS350d
Joined
·
4,379 Posts
You can’t remove it from the outside. Not without breaking something.

Don’t lose the screw inside the door.
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
725 Posts
You will need an extra long 4mm allen..or you have to enlarge the access hole to get an extension in there.. I just opened up the hole just enough to get my 1/4 extension in and when done,.the cap cover still fit and covered the hole..
 
1 - 11 of 11 Posts
Top