Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
2002 ML320
Joined
·
52 Posts
Discussion Starter #1
Hello Forum Members,
I have a hose leak in my drier to expansion valve hose. The hose was rubbing on the ABS module and the rubbing caused wear and a leak. This is likely my doing as I must have pushed down on the hose when I replaced the pressure switch (see post https://www.benzworld.org/forums/w163-m-class/2980954-troubleshooting-ac-system-2002-ml320.html). Bummer for me. In any case, I need to replace the hose. I was wondering if anyone can post some instructions? Here is my plan

1. Order a replacement hose. I believe the part number is 163-500-02-72
2. Evacuate the system
3. Replace the hose. Any guidance here would be appreciated.
4. Evacuate the system
5. Recharge the system
- add oil (I believe I need to add about 0.68 oz referring to AR83.30-P-5252E)
- add dye
- add 26.5 oz of R134a
6. Enjoy ice cold air!

Questions:
1. Should I replace the drier or other parts at this time?
2. The area of the hose leak dispensed a bunch of yellowish-green fluid onto my ABS controller. I assume this is a mixture of R-134a and oil? Seem like quite a bit of fluid. I'm wondering if I require more than .68 oz of oil?
 

Attachments

·
Registered
1999 E430; 2005 ML500
Joined
·
1,738 Posts
It is not a must, but given that it’s 18 years old and you live in Savannah, I would consider replacing ther compressor and expansion valve too. You don’t “need” to, but while everything is apart anyway you end up with a new system with fresh oil for under $300 more. Depends on your expected future with the car.
 

·
Registered
2002 ML320
Joined
·
52 Posts
Discussion Starter #4
Thank you. I've ordered the parts. I'll keep you informed of progress. As always, I appreciate the professional advice on this forum.
 

·
Registered
2002 ML320
Joined
·
52 Posts
Discussion Starter #6
Ok, I got all the parts in and I replaced the following: Expansion valve, drier, hose from expansion valve to drier, seals, and mounting bolts. Evacuated and leak test is good. Can someone confirm the amount of oil I need to add? I know I need to add 0.338oz for drier. I'm not sure for the hose or expansion valve because I don't know if this is a suction hose or other type of hose. I'm thinking the hose is a rear hose that doesn't require additional oil. My initial plan was to add 0.68oz as per AR83.30-P-5252E, but I don't think that is correct.
 

·
Registered
Joined
·
1 Posts
hey Dan I have this exact same problem and am finally fixing it. My new hose is coming Friday. My question is, how difficult was it to replace the long high pressure hose from the drier to the expansion valve? I am looking at everything under the hood and it seems like there will be a fair amount of disassembly in order to get it back in place. It seems like several people had this problem...you can see on my high pressure hose exactly where the ABS module damaged it.

Thanks.
 

·
W163 and General M Gremlin
Joined
·
3,695 Posts
hey Dan I have this exact same problem and am finally fixing it. My new hose is coming Friday. My question is, how difficult was it to replace the long high pressure hose from the drier to the expansion valve? I am looking at everything under the hood and it seems like there will be a fair amount of disassembly in order to get it back in place. It seems like several people had this problem...you can see on my high pressure hose exactly where the ABS module damaged it.

Thanks.
===>>> Please update your user CP info....

click on your icon----> click on Account Settings---->
goto Account Details----> add vehicle details---->
ADD your make model YEAR ----> click save
 

·
Registered
Dallas, Texas
Joined
·
8,187 Posts
hey Dan I have this exact same problem and am finally fixing it. My new hose is coming Friday. My question is, how difficult was it to replace the long high pressure hose from the drier to the expansion valve? I am looking at everything under the hood and it seems like there will be a fair amount of disassembly in order to get it back in place. It seems like several people had this problem...you can see on my high pressure hose exactly where the ABS module damaged it.

Thanks.
Recent post.
 
1 - 9 of 9 Posts
Top