Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
2004 ml500 2006 gsx-r750
Joined
·
64 Posts
Discussion Starter #1
sorry to post about this topic again but i i have had mixed answers and i want to make sure i know everything before i install...i have the fiber optic system and have been told that i have to rewire all the speakers..i want to add an amp as well and i have been told i need a 2ohm stable amp..where is the amp and the sub located..by the way im getting the avic z2
thanks for all your help in advance
also im going to be adding an alarm any advice on that
 

·
Registered
2001 ML430, 1983 300SD, 2008 GL450
Joined
·
904 Posts
Assuming that you have the D2B network then to the best of my knowledge there aren't any common units that will work with this system. So it is likely that you were given the correct information.

The "rewiring the speakers" comment was misleading though. This just means plugging them into the new amp. You will have to run the signal lines from the head unit to the new amp, though. Yes, you will need an amp that can handle a 2 Ohm load. Keep in mind that consumer audio equipment in general and car audio equipment in particular has more than its fair share of complete cr*p being sold.
 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
I offer this for encouragement, but not to over simplify. It can be done. Behold the Avic-Z1. I removed the Bose amp and went only with the 4x50W Avic. I used no compensation for the 2 ohm speakers. You will need to locate the wire to each speaker, but it's not rocket science. The guys I talked to at circuit city did not know what they were talking about. Enjoy!

btw... as soon as the Z3 upgrade is out, I'm updating my z1 to z3.

 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
Just in case you aren't aware of it already, there is also a forum for the Avics...

Avic411 dot com.
 

·
Registered
2001 ML320 w/ AMG Sport Package
Joined
·
79 Posts
I offer this for encouragement, but not to over simplify. It can be done. Behold the Avic-Z1. I removed the Bose amp and went only with the 4x50W Avic. I used no compensation for the 2 ohm speakers. You will need to locate the wire to each speaker, but it's not rocket science. The guys I talked to at circuit city did not know what they were talking about. Enjoy!

btw... as soon as the Z3 upgrade is out, I'm updating my z1 to z3.


Bogie, it's a decent unit! You even have the Mercedes-Benz background on your Z1! :thumbsup: I like it very much and would like to have the Z1 installed in my 2001 ML320 too, now it only has the factory MCS unit.

Question: Where did you go to install the unit? Can you recomended one or two good indie shop to handle this job in the Boston area? And if I am going to install the Z1, I also want to get a rear view camera. Would it be too complicated? Like drilling holes...etc. Please provide some insights. Thanks so much!
 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
I had my unit installed by Tweeter's in Burlington, after Circuit City (across the street) gave me advice that didn't sound right. Installation was expensive, but I really saved on the cost of the unit, which was a floor demo. I let them put it in because I wanted to have a warranty. I got the Ipod interface and the bluetooth module. The camera might be a nice addition as well as XM radio with traffic data for the NAV. I hate that I couldn't connect my CD changer, but with an 80 Gig Ipod and 10 Gig of music on the Z1, who am I kidding?

I made the Mercedes logo with photoshop. I posted the jpg for others. I'm looking for ideas for a new one.
 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
I'm using the Bose sub under the driver's seat and I'm not using an amp at all. I used a custom equalizer setting, simulated sound stage setting to Dynamic Theater, subwoofer output to +5, loudness on, high pass filter 80 Hz, F/R balance to R+5.

I'm not interested in having the neighbors know that I have entered the neighborhood, but it sounds really good.

I may add an amp some day just to see the difference, but for now, I have no complaints.
 

·
Registered
2004 ml500 2006 gsx-r750
Joined
·
64 Posts
Discussion Starter #9
so the sub is under the drivers seat what about the amp where is located
 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
i would go for avic-z2 or avic-z3, + Alpine DX-5 power amp.
the avic z1, avic z2 and avic z3 are the same unit. The only difference is the software. You can buy the upgrade from z1 to z2 for $250 now. Many of us are waiting for the z3 upgrade, hopefully in the same price range. If this is so, make sure you aren't overcharged for the z2 or z3.
 

·
Registered
Joined
·
1 Posts
I ws wondering if you can tell me where I can buy the double din kit for my 2000 ML 320..I am trying to install a new radio..thank you
 
1 - 12 of 12 Posts
Top