Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
Artic White 1995 S420
Joined
·
366 Posts
Discussion Starter · #1 ·
I just turned the car off after I pulled the car in the garage, and I looked under the car and saw a leak! Im very lean so I was able to get under the car and touch the fluid. It was water so I was thinking water pump. The thing is from what I understand the pump is in the front of the car not the center, could it just be a hose come loose or is it the pump? the car runs normally but the check engine light is on and the led diognastic blinks 19 times!
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
You really need to pressure test the system and see exactly where it's comming from. For example I had the same symptoms as you a leak from the left front (when your sitting in the car looking forward) and I'd replaced my pump about 13-14 months prior turned out to be the radiator so you really need to pressure test. The coolant can run over things and end up dripping onto the ground from a completely different place than where the actual leak is.
 

·
Registered
'14 E350, '07 CLK350, '01 SLK320
Joined
·
1,148 Posts
Were you using the A/C? Are you sure it just wasn't condensation draining from the evaporator?
 

·
Registered
1987 560SL - 1994 S420 - 2005 S55 AMG
Joined
·
341 Posts
True if it was water and not coolant.
Normally the coolant will feel slicker then water from the AC. If the car is not running hot I would guess it is AC condensation also. If you are running other than Mercedes coolant (the green or orange stuff) try laying a sheet of white paper under the car and note the color. Of course Mercedes brand coolant is clear so it will only help if you are using the other stuff.
 

·
Registered
1994 s320
Joined
·
514 Posts
Mine leaking as well ,but its coming from the Pump to Block area ,might be an
o-ring/gasket.
 

·
Registered
Artic White 1995 S420
Joined
·
366 Posts
Discussion Starter · #7 ·
yeh its clear and the car runs at normal temp all the time, and it only leaks sometimes. Maybe its just me but the ASR has been clicking on alot! From what I hear thats another symptom of a coolent leak.
 

·
Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,293 Posts
the ASR has been clicking on alot! From what I hear thats another symptom of a coolent leak.
where did u get this handy piece of information from?
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
did you replace any fluid? is the cap the right one and was it fitted properly?
 
1 - 10 of 10 Posts
Top