Mercedes-Benz Forum banner

21 - 27 of 27 Posts

·
Registered
96 E320 W210 MBENZ
Joined
·
69 Posts
Discussion Starter #21
Witek_M you are right on the target and money wire colors are the right match. Wish there was in ledger to d denote actual part name and the parts they connect to if possible???? Today i drove car to work parked it about 2 hours later tried starting it cranked turned but would not fire over or start numerous attempts to shake or wiggle connector NOTHING this time had car towed to my Mechanic so he can go over system
 

·
Premium Member
05 500
Joined
·
6,474 Posts
  1. In answer to all your questions after going 10 miles or so when I rise hood engine heat is felt I can hardly touch my engine or my hoses yet my fans all appear to work and guage reads just a little above 80 degree line and as I also mentioned my wheels are also very hot to touch all the air has been bled out of cooling system. I have been doing some homework and research on reducing heat in engine compartment suggested is Be Cool Extended LifeSuper Duty Coolant or Amsoil Dominator Coolant then wrapping headers also Silcone coolant hose kit or bigger diameter hoses so coolant cools faster and better. This problem of engine heat according to friends who owned BMW their cars would cut off while driving and without any warning they say they had alot of the same issues I have, the dealers told them after 80 to 90k sell it and buy new run it to 80 to 90k that's all their good for before major issues arise.
The answer to your question (as subjective as it is) is NO, it shouldn't get hot to a point where the wheels are hot enough to "melt" the center cap. You have some problems. When I open my hood after a 13 Hr drive, I can touch the motor cover without fear. When I pull the motor cover off, the top part of the motor is usually hot but not to the point of scalding me. The radiator hose, motor case, oil filter and oil filter cooler are hot as expected, and stay hot for several hours. The spark plug modules are not hot to touch, the power steering reservoir is barely warm. My wheels are not hot, though brakes will be hot. Front rotors are actually cool after a few minutes - I have never checked rears. If you wonder why I go to this extent, based on experience with other cars, I try to do whatever I can to evacuate as much heat as possible, as quickly as possible from the engine bay, in an attempt to extend the life of rubber hoses, especially the vacuum hoses, as well as those plastic electrical harness shields. So after a long drive, usually at high speeds, I open the hood to max angle and feel around. So, based on your description, you have a problem.

In another car which I experienced the hot wheel issue (it was really hot), it turned out to be really bad toe issues. The tires were heating up so much that the wheels got super hot. Problem went away after to was fixed.
 

·
Registered
Dallas, Texas
Joined
·
6,985 Posts
Witek_M you are right on the target and money wire colors are the right match. Wish there was in ledger to d denote actual part name and the parts they connect to if possible???? Today i drove car to work parked it about 2 hours later tried starting it cranked turned but would not fire over or start numerous attempts to shake or wiggle connector NOTHING this time had car towed to my Mechanic so he can go over system
Here is legend to diagram above.
 

Attachments

·
Registered
96 E320 W210 MBENZ
Joined
·
69 Posts
Discussion Starter #24
Witek_M thanks so much. I an a bit puzzled by all this because I am faced with new problems the valet key and blade key that opened driver door and I have been using when I go surfing and put my ignition key in the trunk stop opening the door only works in trunk and now I'm being told that the stopping or dying out of the car is related to my alarm system and central locking remote still works fine for locking and unlocking doors. Have you ever experienced this or anyone you've known??? I can't believe this car with 80k org miles can start having all these issues??? Most.everything been replaced accept engine and PCM/ECM how do you know or can tell when computer need replacing appears to be no real Codes to tell you???
 

·
Registered
Dallas, Texas
Joined
·
6,985 Posts
Witek_M thanks so much. I an a bit puzzled by all this because I am faced with new problems the valet key and blade key that opened driver door and I have been using when I go surfing and put my ignition key in the trunk stop opening the door only works in trunk and now I'm being told that the stopping or dying out of the car is related to my alarm system and central locking remote still works fine for locking and unlocking doors. Have you ever experienced this or anyone you've known??? I can't believe this car with 80k org miles can start having all these issues??? Most.everything been replaced accept engine and PCM/ECM how do you know or can tell when computer need replacing appears to be no real Codes to tell you???
Here is how it works.
When you are in possession of vehicle with test light, volt meter and scanner in your hands we will try to help and guide you. Once vehicle is in the shop it is over.
 

·
W221 & Audio Moderator
Joined
·
197 Posts
You may want to try to invoke the method to force the auxiliary fan(s) on high evaluate their performance at keeping things cool. Hold down the AUTO buttons on the climate control on the left and right side simultaneously for about 15 seconds and the fan(s) should speed up to 100% duty cycle. It will remain this way until you turn off the vehicle or repeat the process you did to invoke it.
 

·
Registered
96 E320 W210 MBENZ
Joined
·
69 Posts
Discussion Starter #27
Thanks everyone and to all of you a happy and blessed.new year. Here's an update for all your great advice which I greatly appreciated. My cars running great my MB mechanic went back over entire system reworked everything that might have been possible cause of starting problem fixed the contacts in connector no Mir need to shake it. It fastened back to car. Also fixed trunk latch so it works with inside switch. Flushed cooling system got all new hoses put in MB coolant seems too have solved heat issue got 5 spoke AMG rims more air no more blazing hot rims. Just ordered new slotted drilled vented OEM Rotors for the front with pads and sensors also painting my calipers POR 15 red with MBenz white letter decals covered over with VHT FLAME PROOF clear coat up to 2000F.. Thanks everyone for all your advice and help hope my issues will help others as well great FORUM.
 
21 - 27 of 27 Posts
Top