Mercedes-Benz Forum banner

1 - 20 of 40 Posts

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #1 (Edited)
yes I did it but before i changed it I made sure nothing else was causing the problem.
It all started when I heard a clicking sound coming from inside the center air conditioning vents. Then after a few weeks the A.C. stopped working completely. the it started working again after i messed with the control knobs but only a small amount of cold air would come out. Finally after 2 months the cold air stopped working and only scorching hot air would come out of the vents. I took it to a local indie shop and they tested everything from codes to A.C. parts. We checked the R134a and everything was fine. Pressure was perfect and all parts functioning. He said he could not figure out what was wrong.
So knowing what i learned from other ML owners i finally took on the job this weekend.

It turns out the air blend motor was indeed the problem. Once I removed the air bag I could actually see the motor was clicking. It would also slip back into heat mode and close the cold air flap completly when i set the fans to high (4).

My DIY Video could have been better, but hey ask me any questions and I will be glad to help you. First thing i suggest is finding a person with very small hands to remove the two screws holding down the air blend motor. But before that you will need to push the airbag cover off from underneath untill the two plastic tabs break. Then uncrew the three nuts holding the cover down. The rest is cake


Total time to do this job is 1 hour.
 

·
Premium Member
2006 E55: 1999 ML430; 2002 E430 4matic; 1988 190E 2.3; 1993 XL883
Joined
·
301 Posts
Wow, great job. And all in 1 hour. The vid makes it look easy. Thanks for posting.
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #5
Wow, great job. And all in 1 hour. The vid makes it look easy. Thanks for posting.

In my Elvis Voice:
(Thank you, thank you very much, thank , thank you very much).


I have gone online and have seen people have had this same problem with the air blend motor ( air flap actuator ) for years. They have paid over $1,800 just to get it fixed.
The Dealer said it would take them 8 hours of labor plus parts. I said [email protected]#K that!
Hope this helps everybody.
 

·
Registered
'08 Acura MDX
Joined
·
3,108 Posts
It all started when I heard a clicking sound coming from inside the center air conditioning vents. Then after a few weeks the A.C. stopped working completely. the it started working again after i messed with the control knobs but only a small amount of cold air would come out. Finally after 2 months the cold air stopped working and only scorching hot air would come out of the vents.
My ML had EXACTLY the same symptoms. After getting a repair quote from the dealer, and considering the repair costs I had already incurred, and things that would still need to be fixed, etc. - I gave up and traded.

Who knew it was this easy?

Thanks for taking the time to make the video and post it. I'm sure it will help MANY people! Good job!
 

·
Registered
1999 ML320
Joined
·
24,029 Posts
In my Elvis Voice:
(Thank you, thank you very much, thank , thank you very much).


I have gone online and have seen people have had this same problem with the air blend motor ( air flap actuator ) for years. They have paid over $1,800 just to get it fixed.
The Dealer said it would take them 8 hours of labor plus parts. I said [email protected]#K that!
Hope this helps everybody.
Impressive !
How does the dealer justify 8 hrs ?
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #8
Impressive !
How does the dealer justify 8 hrs ?
they say they must remover the entire dash board, the console, the air bag, and other parts they say they need. after doing this job on my own I think they are full of [email protected]#T. I do agree with removing the dash board part because by doing so you avoid having to break the small air bag clips. But considering and comparing the cost of the clips its a no brainer to do it how i did it.

Me some Engineer buddies of mine who work for Hughes Aircraft agree that there is always more than 3 ways to solve a problem, and more than enough people who say you can't.
 

·
Registered
99 ML 320 (dearly departed), 03 E 500, 05 FX35 (Sold), 07 Cayenne S (Sold), 06 Cayenne Turbo
Joined
·
616 Posts
Very good video, I love the fact that you actually did this and I wish the almighty Plubner (sp?) had a video camera because I could have saved thousands on repairs just seeing it done.

Lastly, think I missed the cost of the part. Please let me know. :thumbsup:
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #10
Very good video, I love the fact that you actually did this and I wish the almighty Plubner (sp?) had a video camera because I could have saved thousands on repairs just seeing it done.

Lastly, think I missed the cost of the part. Please let me know. :thumbsup:


$97 @ the dealer.
 

·
Registered
B200 Turbo
Joined
·
222 Posts
Thank you very much for posting this video - it is very helpful.

One question - at the end you say put the air bag with crazy glue? Is there a reason for this? I notice you mention that clips need to be broken. Is there a way to replace the clips properly without the need for glue?

Thanks again!

Jeff
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #12
Thank you very much for posting this video - it is very helpful.

One question - at the end you say put the air bag with crazy glue? Is there a reason for this? I notice you mention that clips need to be broken. Is there a way to replace the clips properly without the need for glue?

Thanks again!

Jeff
There is no way to replace them... =/
 

·
Registered
N/A
Joined
·
23 Posts
There is another small motor which pumps hot water (if you select heating) into the dashboard.... i had this all rusted . it fits along with control unit shown in the video.

The video is good.. but it wudnt help me in my case, since my car used to give only cold air summer time, but not hot in winter. il post part numbers tomoro
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #15
There is another small motor which pumps hot water (if you select heating) into the dashboard.... i had this all rusted . it fits along with control unit shown in the video.

The video is good.. but it wudnt help me in my case, since my car used to give only cold air summer time, but not hot in winter. il post part numbers tomoro
the motor controls a flap that opens the hot air and the cold air. In my case i would only get hot air.. Other cases of this same problem say they only got cold air. So it may just be the same issue in your case
 

·
Registered
99 ML430 - 13 328i
Joined
·
1,112 Posts
when i have the knob turned to ac now it keeps ticking, but the sound goes away most of the time. but the ticking is very loud on the ac side. then in the winter, i remember that when i turned the knob to heat it would tick but more quiet.is it the air blend actuator? cause for this i'm just gonna let my mechanic do it, im not gonna tamper with the airbag.
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #17
when i have the knob turned to ac now it keeps ticking, but the sound goes away most of the time. but the ticking is very loud on the ac side. then in the winter, i remember that when i turned the knob to heat it would tick but more quiet.is it the air blend actuator? cause for this i'm just gonna let my mechanic do it, im not gonna tamper with the airbag.
YUP.. IT SOUNDS LIKE IT IS.. the tick is the boken motor gears not making proper contact.

your meachanic is going to go to Canncun with the money he makes from you
 

·
Registered
99 ML430 - 13 328i
Joined
·
1,112 Posts
hey detane. me and my dad were talking about getting it fixed, so he popped out the center ac vents and he was able to actually push on the pin, from what he said, and the ticking went away. i guess this confirms its the abm.
 

·
Registered
1997 W210 E320, 1999 W163 ML430, 2002 W203 C240
Joined
·
761 Posts
Discussion Starter #20
hey detane. me and my dad were talking about getting it fixed, so he popped out the center ac vents and he was able to actually push on the pin, from what he said, and the ticking went away. i guess this confirms its the abm.
yup... I did m homework first to make sure that was the problem on my ride. Ticking is the main sign of this problem on all ML's.
 
1 - 20 of 40 Posts
Top