Mercedes-Benz Forum banner
1 - 20 of 55 Posts

·
Registered
2006 R230 SL55 AMG
Joined
·
48 Posts
Discussion Starter · #1 · (Edited)
I am writing this DIY as I don’t find the instructions in WIS to be very informative. It describes how I replaced my own ABC pump after my local dealer wanted to charge over $8k for the job, due to an occasional red ABC Drive Carefully warning on my dashboard, and me needing to re-prime my pump every few hundred miles. I am happy to modify this DIY with feedback or other advice. This work is done at your own risk, I take no responsibility for you skinning your knuckles, damaging your car or anything else by using these instructions!
Total time taken to remove and reinstall the pump was about 5 hours and 2 beers, including taking pics and notes. I spent another hour or so filling and bleeding the ABC and power steering. The pump was a remanufactured unit I bought off ebay for $400. Banjo O-rings were replaced with new ones.


Tools needed

Sockets
8mm (for undertrays)
10mm deep socket
17mm (and long breaker bar for belt tensioner)
19mm
E10 torx
E12 torx
Short and long handled ratchets
Torque wrench

Wrenches
17mm flare wrench
19mm flare wrench
19mm box wrench / ring spanner

Other tools
Hose clamp pliers
Hose crimping clamps to reduce fluid leakage
Flat head screwdriver
Jack stands
Jack
Lots of shop towel / rags to clean up spillages
Drain buckets
Some way to apply a little air pressure to the reservoir after reassembly to prime the tandem pump (I use an air compressor with a rubber bung with a hole through the center)

Consumables and parts
ABC Tandem pump, part number 0034662701 or 0034665001
4x green banjo bolt o-rings, part # 0289976548 or 028-997-65-48
10 litres of Pentosin CHF11S for ABC system (bought from Amazon)
ABC reservoir filter 0031846101 (bought from Amazon)
Plastic hose seals or caps, or kitchen wrap and rubber bands to temporarily seal off hoses etc to prevent contaminating the system with dirt.


Step 1
Remove the engine trim plastics and filter intake hoses. WIS says to remove the fan shroud but this is not necessary. (I was unable to get mine out through the gap without removing coolant hoses, and discovered it didn’t need to be removed anyway.)
Remove the front center 2 undertrays from beneath the engine at this time, using an 8mm socket. Try to clean all the areas thoroughly with degreaser where you are working to reduce the risk of getting contaminants into the ABC or power steering system.


Step 2
Loosen (do not remove yet) the 3 e-torx bolts holding the pulley to the ABC pump, then remove the serpentine belt. To remove the belt, put a 17mm socket on the belt tensioner, release the tension by turning the bolt to the left and slide the belt off the pulleys. Make sure you review the diagram (see lower down the page) of the belt routing before you do this so you are clear how it goes back on. Leave the breaker bar on the tensioner, as you need to move the tensioner pulley aside again to remove one of the ABC pump etorx bolts. Inspect the belt for cracks or wear and replace if necessary.
Now remove the 3 ABC pulley etorx bolts and remove the pulley from the ABC pump.


Step 3
Siphon, pump or syringe out the fluid from the ABC and power steering reservoirs using very clean equipment. Do not let any contaminants get into either tank.


Step 4
Put drip trays under the car to catch dripping hydraulic fluid.
Remove the hose clamps from both of the hoses on the ABC pump, then remove the hoses. I used crimping tools to try and reduce the fluid spilling in the engine bay, but I still lost a fair amount. Cap and seal all hoses as you remove them, I used kitchen wrap and some plastic caps I had in my workshop.


Loosen the hose clamps from the 2 hoses where they go to the power steering reservoir and ABC reservoir, then pull the hoses from them.


Step 5
Remove the front 2 of the three 10mm bolts holding the reservoir assembly in the car, then loosen the 3rd nut that attaches the bracket to the strut tower. This nut doesn't need to be removed entirely. Then remove the assembly and place in a drip tray. You will probably have some spillage here. Try to cap off the hoses and clean the units.


(Pic shows bolt locations with the assembly already removed from car)


Step 6
Remove the two 19mm banjo bolts on the ABC pump to release the hoses. The rear hose has a bracket that is held in place by one of the AC compressor bolts. Remove that one from beneath the car. You may also find it easier to remove the rear banjo from below, but wear eye protection as it will leak when you undo the bolt.
Remove the earth strap etorx bolt


There is another metal hose that needs to be undone from the side using a 17mm flare wrench. Undo the etorx bolt that holds the metal hose bracket to the ABC pump then move this hose out of the way.


Disconnect the electrical connector from the ABC pump.

Step 7
Remove the 2 etorx bolts on the front of the ABC pump. You will need to move the belt tensioner using the breaker bar to access one of the bolts.
The rear of the pump is held in place with a nut through an engine bracket onto a captive stud in the pump. In order to access this nut, you need to remove the cylinder that the banjo bolts go into from the ABC pump. It is held in place by 2 etorx bolts which are not so easy to access. One is under the bracket shown in the pic, the other is at the other end of the bar and bolts into the engine block by the exhaust manifold.

To access the ABC pump bolt, use a short extension beneath the bracket pointing towards the front of the car.
To access the engine block bolt, best access is from beneath, between the AC unit and the engine. You can get an arm up there and see the bolt.


This is the banjo unit removed from the pump so you can see the bolt hole locations more clearly.


Step 8.
Slide the cylinder and bracket aside so you can access the last nut that holds the pump in place. Remove the bolt, then the ABC pump can be removed from the car. You will likely spill more fluid as you maneuver it out of the car. Clean up all the spillages and degrease the work area.

Step 9
Have a beer, cup of coffee or whatever floats your boat.
Wash your hands or replace your gloves before reassembly, in order to reduce risk of contaminants getting into the ABC system during assembly.
Reinstall the new pump in the reverse order of the steps above.
I used Loctite and 25nm as the torque setting for all the etorx as I replaced them.
Replace all 4 banjo o-rings by removing the old ones with a small pick. The o-rings may be difficult to pick out of the hose face, make sure you don't scratch or damage the hose face or you could get leaks. The banjos need to be carefully done up so as not to cross thread them. (You may need to replace both the pump and the hose if you cross thread!) I tightened these as much as I could using a long 19mm box wrench. I found the rear banjo to be awkward to engage the bolt onto the thread, due to the tension in the metal hose.
Refill the reservoirs and check for leaks.
Prime the ABC pump by rotating the pulley to pump fluid through the pump. (I couldn't detect much change in the fluid levels when I did this.)
Top up the ABC reservoir again.
Put the serpentine belt back on as per the diagram below.


Prepare your air pressurizing kit to prime the ABC pump again.
Start the car with a helper while you check for leaks. Put a few bar of air pressure into the ABC tank to prime the pump for 15 seconds or so. Keep an eye on the fluid level and top up as required to maintain the levels. Get the helper to cycle the ride height switch to make sure the car rises and lowers OK. This means the pump has successfully primed itself. Rising and lowering the car will bleed the system, as will just driving it around.

Get the helper to turn the steering fully left and fully right until bubbles stop coming into the power steering reservoir. Top up as necessary. Mine was OK after about 10 turns lock to lock.

You may need to get any old ABC error codes cleared from your car using a code scanner or DAS system. I have a Chinese DAS laptop, so I can clear my own codes.

Go and buy a holiday or a weeks supply of beer with the $7k you just saved for one day’s work…
 

·
Premium Member
2003 SL500, 2012 E350 4Matic P2
Joined
·
841 Posts
Very nice write up indeed !! Thanks for taking the time to do the step by step with pictures. First hand experience is always priceless!! I've copied it for future reference as I know for sure that a pump change/rebuild is in my future at some point.

Couple of questions. What symptoms were you having that caused you to finally have to change out your old pump? Was your pump noisy, low pressure leaky etc?
Did you ever consider rebuilding the pump yourself with the seal kit available from Invasion Products?

Finally, who did you source your pump from?

Thanks again,

Bob
 

·
Registered
2006 R230 SL55 AMG
Joined
·
48 Posts
Discussion Starter · #4 ·
The symptoms in my car were as follows:

-Inconsistent and vague suspension.
-Wobbly ride, with the feeling that the struts were at different pressures
-Weekly ABC red 'Drive Carefully' warnings
-ABC pump needed to be primed every week
-Overflowing ABC reservoir after switching off car
-Leak from somewhere in the pump area

Mercedes here quoted $7k for the ABC pump, plus $850 to flush the fluid. They also wanted $3k for the pressure accumulators and $2750 for the front left strut.
I replaced all the pressure accumulators for around $600 but still got the ABC warning.
Then I flushed the fluid for $120 using genuine parts from Amazon.
Still getting the ABC warning so I decided to do the tandem pump also, cost $400.

This is the company who supplied it. There is a $60 core charge on my old pump.

Pacific Exchange Parts Rebuilders Inc
7442 Deering Ave
Canoga Park
CA 91303
(818) 703-0821

I didn't know about the rebuild kit, perhaps next time I would tackle that also.
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
thanx

thanx for the pix and the article, i'm doing the exact job now, i'm at the banjo part, are you sure it's a 17mm on the side? my 17mm is loose and i'm afraid i'll strip it, don't have a 16mm but will go to sears and pick one up.
is your rebuilt still functioning well? i'm in cali and don't know if i want to get it from premier or buyautoparts
thanx again
 

·
Registered
2006 R230 SL55 AMG
Joined
·
48 Posts
Discussion Starter · #7 ·
I don't remember exactly, as I have the full set of Snap-on flare wrenches. I don't remember using any flares other than 17mm though.
My pump is still running great.
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
thanx, i'm at a stand still right now. i'm following your lead. i can't get the 2 banjo nor the 17mm nut (w/ the tube thru it) off. i must be using the wrong tools, i hope. all my tools are in ny but the sl and i are now in cali. did you use stubby wrenches, crows feet wrenches? i've starting stripping the 17mm nut and ran out to get the 17mm flare. i don't have a 19mm flare and wasn't able to find one at sears.
any suggestions?
thanx,
 

·
Registered
2006 R230 SL55 AMG
Joined
·
48 Posts
Discussion Starter · #9 ·
You MUST use flare wrenches for the hydraulic fittings. They are more accurately constructed and will not strip the heads on the hydraulic fittings. I bought used standard length Snap-on flare wrenches off ebay, cost around $75 for the full set.

Amazon or Harbor Freight should be able to deliver you a flare wrench set in 24 hours if there are no local tool shops that can sell you a Craftsman set or any local Snap-on trucks.
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
there is a harbor freight near me. what about the semi stripped nut? any thoughts? you bought your pump from premier, i assume you're happy w/ them?
thanx again for your help it's greatly appreciated.
 

·
Registered
2006 R230 SL55 AMG
Joined
·
48 Posts
Discussion Starter · #11 ·
You may have to force the flare wrench onto the stripped nut, depending how bad it is. Replacing that hose is probably not very straightforward, I am not sure what it routes through or how long it is. If it is totally ruined, you may need to file new edges onto it and use an adjustable wrench or use grips on the wrecked head then replace the whole hose.

I am pleased with the pump I bought.
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
FINALLY got the pump out, now just have to order another pump, will probably go the remfg route,
thanx again for your help!
regards,
andrew
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
so everything is installed, no leaks, but i am getting the red code and the car isn't rising. i put fluid in the pump, spun the pulley approx 20 x's. topped off the res and added air to the dipstick, any thoughts?
thanx
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
If that's the 2 wire plug on the top of the pump, yes it's connected I reseated it in case it wasn't making good contact
 

·
Registered
2006 R230 SL55 AMG
Joined
·
48 Posts
Discussion Starter · #18 ·
How did you add the air in the dipstick hole? Was the engine running when you pressurized it?
Engine must be running and you must have a reasonable amount of pressure, enough to make the reservoir bulge very slightly. I used a small air compressor connected to a cone shaped rubber bung with a hole through the center. The pressure delivered was maybe 30psi for about 2 secs. The pump primed almost immediately and I watched the pressure in the system climb from 0 bar to 200 bar in about 20 seconds (using my Chinese DAS system). After that, it has worked perfectly ever since, no more warning lights and the car rises and lowers on the button.
 

·
Registered
2003 sl500, 86 300e, 76 911s, 81 308gtsi, 99 range rover hse, 96 320sl, 97 320sl
Joined
·
15 Posts
i used an air compressor thru the dipstick hole. i started the compressor when the engine was off, i wanted to be able to feel the air push fluid into the hose that is attached to the pump. i then started the engine and pulsed the compressor for approximately 30 seconds.
it's a week and the car is the abc system is working great, this rebuilt pump is noisier than the OEM

another ? - oil levels, i have been getting oil level too high and the stealership said it's a defective oil level sensor. i just bought a dipstick and it shows 180mm on the dipstick, the chart associated w/ the dipstick notes approx 145mm as being topped off. have you used a dipstick on your sl and if so what mm level do you have when topped off?
thanx again for all your help it's greatly appreciated
 

·
Registered
2002 S-500
Joined
·
2 Posts
I have replaced my struts with Strutmaster air shocks. Two week after that the fluid got low and the pump went belly up un me and I now have no power steering now. Any advice on how I can replace the pump with a power steering only pump? I see lots of discussion here that it can be done but no real specifics. Great instructions on the removal. I have a 2002 S500.
 
1 - 20 of 55 Posts
Top