Mercedes-Benz Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Anyone else with an '08 S550 4Matic having an issue with repeated shut off of the Distronic Plus? Operates fine for a period of time, then gives the "Distronic Plus Unavailable" message in the display. Eventually it resets itself and gives the "Distronic Plus Available" message. This is annoying!
 

·
Registered
Joined
·
10,427 Posts
Anyone else with an '08 S550 4Matic having an issue with repeated shut off of the Distronic Plus? Operates fine for a period of time, then gives the "Distronic Plus Unavailable" message in the display. Eventually it resets itself and gives the "Distronic Plus Available" message. This is annoying!
I believe I've only seen this once and it was from a lot of slush on top of the grill or the plastic cover for Distronic, not just a bit of snow. If your nose (I mean the car) is clean, it must be and issue with the radar unit or perhaps some CAN wiring. Diagnosis should show the real issue (please report).

Very early cars had a SW issue with the short range radars but this should not apply for a 2008 car.
 

·
Registered
Joined
·
42 Posts
Anyone else with an '08 S550 4Matic having an issue with repeated shut off of the Distronic Plus? Operates fine for a period of time, then gives the "Distronic Plus Unavailable" message in the display. Eventually it resets itself and gives the "Distronic Plus Available" message. This is annoying!
Just had a similar situation. I'm on the west coast so snow wasn't the issue. Was intermittent. Because I had a scheduled service the following week, I mentioned it to the service guy. They have told me that the "switch" needs to be replaced. Am having that done tomorrow. I have this suspicion that this replacement is due to them not being able to figure anything else out. I've come to rely on Distronic Plus as I have a pinched nerve and cannot leave my right leg in one position for very long. And I am getting ready to drive to Tucson next week (13 hours) so don't want to take any chances
 

·
Registered
Joined
·
10,427 Posts
There was a similar issue which was fixed by a SW update for the short range radar units but this was for very early cars, definitely not for one from 2008.
 

·
Registered
Joined
·
686 Posts
Distronic Plus will go unavailable if the system senses interference on the K Band or W-Bands. Basically its a safety feature that makes sure that system shuts down if there is too much interference to function properly.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Just to close the loop -- they installed a new radar sensor unit and recalibrated the system. (BTW, the sensor unit is close to $2,000, and it sits in a vulnerable spot). Problem resolved.
 

·
Registered
Joined
·
42 Posts
I never had the "problem" handled by MB. Very intermittent. I've found that if I pull over, kill the ignition, and restart, Distronic starts working. Always works for my computer, so tried a reboot on the car and it worked.
 

·
Registered
Joined
·
13 Posts
I never had the "problem" handled by MB. Very intermittent. I've found that if I pull over, kill the ignition, and restart, Distronic starts working. Always works for my computer, so tried a reboot on the car and it worked.
I have had this problem three or four times, always due to smashed bugs on the plastic cover (part of grill) over the distronic receiver in front of the radiator. i clean off the bugs, and distronic works again.
 

·
Registered
Joined
·
10,427 Posts
I have had this problem three or four times, always due to smashed bugs on the plastic cover (part of grill) over the distronic receiver in front of the radiator. i clean off the bugs, and distronic works again.
Sounds odd if a few killed bugs can kill the radar. I've had some snow slush on the grill and it was still working. Only when a lot of slush piles up, it turns off (I believe this has happened only once for me, and it is more likely to me than someone from California :) ).
 

·
Registered
Joined
·
13 Posts
Sounds odd if a few killed bugs can kill the radar. I've had some snow slush on the grill and it was still working. Only when a lot of slush piles up, it turns off (I believe this has happened only once for me, and it is more likely to me than someone from California :) ).
the distronic is disabled with 100's of bugs...in florida, these are the 'love bugs' that coat the car....and in the summer in northern minnesota hitting swarms of bugs on a warm night...the distronic cover is layered with bug guts....when i stop for gas, i clean them off and the distronic is back in business.
 

·
Registered
Joined
·
10,427 Posts
the distronic is disabled with 100's of bugs...in florida, these are the 'love bugs' that coat the car....and in the summer in northern minnesota hitting swarms of bugs on a warm night...the distronic cover is layered with bug guts....when i stop for gas, i clean them off and the distronic is back in business.
I see, makes sense then, we don't have that stuff and could not think of it being that serious.
 

·
Registered
Joined
·
75 Posts
I never had the "problem" handled by MB. Very intermittent. I've found that if I pull over, kill the ignition, and restart, Distronic starts working. Always works for my computer, so tried a reboot on the car and it worked.
This happended all the time on my w204. first the Disktronic would go out then later or right after it would say Cruise Control Unavailable.. and once i would turn the car off and on agaiin it'd work. i sold the car, so i never knew wat the result was
 

·
Registered
Joined
·
10,427 Posts
This happended all the time on my w204. first the Disktronic would go out then later or right after it would say Cruise Control Unavailable.. and once i would turn the car off and on agaiin it'd work. i sold the car, so i never knew wat the result was
On a 204 with factory options, it cannot be distronic radar related but an intermittent failure could be from a bad "brake switch" or tyre size difference or an ABS sensor/wiring issue on both cars.
 

·
Registered
Joined
·
1 Posts
I have a '06 S500 in the United Kingdom (badged in US as S550). The distronic unavilable message comes up intermitently since I bought the car in 2008. MB said this was possibly down to the plastic lamination I had on the front and rear buper to avoid damage from stones. I have now realised that the problem only occurs when I am near a Mazda or Jaguar and presume their is a conflict between the Mercedes' and their radar or other parking aid system. I doubt every Jaguar and Mazda has radar cruise control so more than likely it is their parking aid system that casue the problem, but it will happen with every Mazda that I overtake. Is their any solution to this, and does anyone have experience of Mercedes sorting this problem even though the warranty has now lapsed (becasue it was reported to them within the warranty period and this new info which may show a design problem with the system has only become available now)
 

·
Registered
Joined
·
342 Posts
I used to have this problem on my 2008 S500. It was either due to dirty plastic distronic shield or after long hours of driving. The latter was fixed by replacing distronic battery (under warranty) and updating the software. Works well since then.
 

·
Registered
Joined
·
68 Posts
Just purchased a "new to me" 2004 W240 and this occurred repeatedly when I drove the car home 600 miles from purchase location to home. Finally, just gave up and used my right foot to modulate the speed. Was not much traffic, so not really a bother. If anybody cares to share more recent thoughts on the issue, please chime in. I guess the best is just to have M-B service give an opinion...
 

·
Registered
Joined
·
29 Posts
My observation got a 2010 factory grill with hand signed from factory initial on the back;

Only ever had this problem during snow. With heavy snow and the slush it brings message it's regular heading to the ski fields on the motorway at speed.
Lots of bugs dusk and dawn during the warm months at high speed travel never had had a inoperative message.

A great system I do love my v221 having a conflict tonight about a v222. I feel the 222 is over styled to compensate for the same chassis. However the tech updates and the interior design sell the car. Very close to pulling the trigger on a 2014 s500 plugin to replace my much loved 500 4matic. The one issue I have with the w221 are the weak brakes on the new plug in 222 I see they are 6 pots on larger discs.

I think I'll put the money to trade into a new set of front 6 pots for my 221 and polish it now the winter wheels are off :)
 

·
Registered
Joined
·
6 Posts
. I have now realised that the problem only occurs when I am near a Mazda or Jaguar and presume their is a conflict between the Mercedes' and their radar or other parking aid system. I doubt every Jaguar and Mazda has radar cruise control so more than likely it is their parking aid system that casue the problem, but it will happen with every Mazda that I overtake.
I have the same observation like you. When I stop on lights close to mazda 6 my distronic go to 'unavailable mode'. After I overtake mazda problem disappears.
 
1 - 20 of 20 Posts
Top