Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all,
Driving 2009 G500. Front and rear lockers engage properly, but they tent to disengage usually while driving in terain. Replaced with new original Vacum pump, still got the problem.

Any idea how to solve the issue? Most of the piping is new, including solenoids.

Thank for any help,
 

·
Registered
Joined
·
3,093 Posts
When was the last time you did the Hydraulic Service? (Brake Fluid Power-Flushing of the Lines)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I never touched the hidraulic system. Got the car for 2 years and the last owner never used the lockers.
 

·
Registered
Joined
·
1,934 Posts
I never touched the hidraulic system. Got the car for 2 years and the last owner never used the lockers.
Per MB, the system needs to be flushed every 2 years whether you use it or not. Not sure why, but crud does accumulate in the hydraulic part of the system and that definitely affects both lockup and release.

Aside from that, I would T a vacuum gauge into various lines and make sure that the vacuum is really holding. All it takes is a small crack somewhere hidden. Another source of leak is the big vacuum diaphragm inside the transfer case. Your G is probably too young for that to be a problem. however, in 5-10 more years that will leak to the point that the center won't lock.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks for the advice AlanMcR,

Well, The only thing working as needs is the center locking, so as of now, no problem in the transfer case. But I sure going to work on the hidraulic parts/oil.

As for the vacum leaking, I did some checking yesterday, the new vacum paump works exactly as the old one. When I click to operate the rear / front locker, it works for 2-3 seconds max, seems like it doesn't produce much vacum, and then works intermitent every few minutes for not more the a second, just a touch. So, it doesn't seems like a vacum leak, looks like it is just don't work properly?

Up to about 6 months ago, the old pump used to work continuesly since I operated the center locker and then the rear / front, it just didn't stop, but the lockers were working, then my mechanic changed some pipes near the solenoids and the T connection to new ones, and since then I got the disengaging problem. Doesn't seems like leaking, is it?
 

·
Registered
Joined
·
1,934 Posts
Sounds like the leaks are gone. But a cheap vacuum gauge will tell you a lot. The leak that you had earlier allowed dirt into the system. The valves could have gotten gummed up and now they are no longer applying full vacuum to the intensifiers.

Then there is the glop in the hydraulic lines. I've seen pretty disgusting fluid come out of a ~2yo G. In that case the lockers applied, but would not release. Not fun on a twisty trail.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Sounds like the leaks are gone. But a cheap vacuum gauge will tell you a lot. The leak that you had earlier allowed dirt into the system. The valves could have gotten gummed up and now they are no longer applying full vacuum to the intensifiers.

Then there is the glop in the hydraulic lines. I've seen pretty disgusting fluid come out of a ~2yo G. In that case the lockers applied, but would not release. Not fun on a twisty trail.

Yossi @ iCruise.co.il‏ <[email protected]‏>
יום ג׳, 20 באוג׳, 13:24 ‎(לפני 19 שעות)‎
אני





Well, I replaced the valves just few months ago.

May it be that there is a blockage in the vacum pipes somewhere, and this is causing the pump to come to the vacum pressure really fast, and also prevents the system to hold the right vacum pressure?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Hi,
Just updating this morning I bleeded the lockers, oil came out a bit ugly, and then tested the car in terrain. Everything is working perfect, lockers engage after seconds, and dissangage almost immediatly. Lockares do not dissengage during using them by themselves. PERFECT! Thank you.
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
3 Participants
cruise
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top