Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
On my primary filter I am getting little black particles in the filter and they are clogging my filter. I have taken the fuel tank out and had a radiator repair shop steam it out. It was dried and new filters were put on. It is a diesel and I ran a diesel purge thru the engine. Where would these little black particles be coming from. They build up within 150 miles??? Any help would be appreciated.
 

·
Registered
Joined
·
780 Posts
Have you changed all your fuel hoses lately? Sounds like one is falling apart, its a cheap fix, and should be done every few years anyway
 

·
Registered
Joined
·
10,152 Posts
Yeah, like torq, the only thing I can think of is the rubber fuel lines between the tank and primer pump may be deteriorating.
 

·
Registered
Joined
·
158 Posts
Discussion Starter #4
Replaced the hose from the steel hose to the primer bulb and was able to drive 250 miles home without a breakdown. Are there lines coming from the tank under the car that should also be replaced. I will replace the cigar hose as soon as I obtain one. Thanks for the info. hard to believe that little 3 inch hose could cause all the problem.
 

·
Registered
Joined
·
10,152 Posts
Replaced the hose from the steel hose to the primer bulb and was able to drive 250 miles home without a breakdown. Are there lines coming from the tank under the car that should also be replaced. Yes I will replace the cigar hose as soon as I obtain one. Thanks for the info. hard to believe that little 3 inch hose could cause all the problem.
Cigar hose, pricey, can use a regular fuel line.
 
1 - 7 of 7 Posts
Top