Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi. I'm in the UK. For 4 years I had a CDI 320, born March 2005, and every year the clock automatically adjusted for daylight saving. 6 months ago I traded it for a 320 petrol, identical model, born Dec 2004 (4 months older but half the mileage and I no longer wanted a diesel engine). But not only did this car not adjust the time but also the menu option to manually adjust the date/time does not exist in the menu settings. How can I fix this?

In case it's related, also the SatNav doesn't work. The car will recognise where it is but if I try to plan a journey it fails to load.

The VIN is WDB2110652A713318
 

·
Premium Member
'71 Pinto
Joined
·
4,427 Posts
Not certain about missing menu but I’m thinking start with GPS reception. Check antenna line if fine, you may need to replace antenna (part # 2118203575 + adhesive foil 2118170021) see attachments.
 

Attachments

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I did mention it to a mechanic Mercedes-Benz garage and he also wondered if maybe updating the maps CDs in the boot might help. Is that a possibility? I'm never likely to use the sat nav so I don't want to spend a load of money updating the CDs if that's not going to help
 

·
Premium Member
'71 Pinto
Joined
·
4,427 Posts
On this note, remove current disc (trunk navigation module) to check disc condition and (as best you can) if processor drive is clean, reload disc in open air environment/clear view to satellites.
 

·
Registered
MY05 CLK55 AMG ,CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Joined
·
1,699 Posts
My 2004 MY2005 CLK320 has a similar problem..it used to adjust time automatically and sat nav knew direction of travel. I never had a disc for GPS.
Then about a year ago for no apparent reason the clock would not adjust automatically and the car did not know direction of travel.
If I attempt to set the time in Comand ,,it says ,,No GPS Data available.
I fitted another gps antenna and it made zero difference.
I believe it is a software problem with Comand ,,like the Y2K bug ,,where after 15 years it no longer functions properly..
The only way I can set the time is by disconnecting and later reconnecting the battery at exactly 12.00.
If anyone knows a better solution ,,please advise.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,006 Posts
I do not know for sure about the Euro/UK versions, but for my car until I get a new splitter for the sat signals installed I had to switch to adjusting the clock from the gauge cluster and steering wheel buttons.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,006 Posts
Interesting.......I get a splitter I am going to test the antenna's impedance. Then check for any corrosion at all the connections before buying one. The wagons do not have the same issue with water ingress into the back so I have a feeling the splitter is out. I have been getting terrible reception for Sirius starting last year. I did pull the antenna and the connections looked good. Even swapped it with a lightly used one, but no change.
 

·
Registered
1999 E320, 2000 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,729 Posts
The only way I can set the time is by disconnecting and later reconnecting the battery at exactly 12.00.
If anyone knows a better solution ,,please advise.
Supposedly the W209 is based on the W203 platform..........I adjust my clock thru the menu available by pushing the buttons on the steering wheel.

Mine changed automatically for daylight saving time, but it is out of sync because daylight savings time was changed in 2007. I have it set on manual mode now.
 

·
Registered
MY05 CLK55 AMG ,CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Joined
·
1,699 Posts
Thanks guys ,,
Unfortunately the MFD/steering wheel menu does not give me a clock set option and the Comand itself , which is how I used to change it if needed ,,now just says no gps data available and that's it.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,006 Posts
It should come up on the center gauge in the binnacle.

It took me a bit to find it and used my manual to finally find it. It was in the owners manual not he COMAND manual. The Controls In Detail>Control system had the info. I had to turn off synch with COMAND and then manually adjust to the current date and time using the steering wheel buttons.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #13
I've followed several YouTube videos on changing date/time using the centre console menu system and steering wheel buttons and the date/time option simply doesn't exist in the menu. I'll try konigs suggestion of ensuring the nav disc is clean once it stops raining here in UK!
 
1 - 13 of 13 Posts
Top