Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2003 W211 270CDI + 2000 w163 ML320
Joined
·
8 Posts
Discussion Starter #1
Hi to all,

I've bought a ML320 from 2000 in September. 3 of the dashboard lights don't turn on at startup

Security belt, Engine check and airbag off :

2611644


I've checked the bulbs and they are OK, in addition, I don't have any error codes with an autel MD802 all systems.
So I wonder if that's normal ?

Many thanks in advance !
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
516 Posts
On my 2000 ML320, position #1.. AIR BAG OFF is "ON".. position #2 it's "OFF"... SEAT BELT is "ON" in #2.. CHECK ENGINE is "ON" in #2.. You might want to take off your gas cap to see if it will throw a code and turn on the CHECK ENGINE light...
 

·
Registered
2003 W211 270CDI + 2000 w163 ML320
Joined
·
8 Posts
Discussion Starter #3
Thanks, good point for check engine... And I'll recheck this WE in position 1 for the airbag...

For the belts, if you run without fasten your seat belt does it sounds ? Mine doesn't
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
516 Posts
"For the belts, if you run without fasten your seat belt does it sounds ? Mine doesn't "

YES.. it beeps.. But it might go out after a while.. not sure, I've always got my belt on
 

·
Registered
2003 W211 270CDI + 2000 w163 ML320
Joined
·
8 Posts
Discussion Starter #5
Ok thanks, I suspect one of the previous owners didn't like to fasten his belt :) is there any fuse for each lights ?
 
1 - 5 of 5 Posts
Top