Mercedes-Benz Forum banner

21 - 27 of 27 Posts

·
Coupe/Convertible Forums Moderator
Joined
·
18,857 Posts
Are you sure it's allen head bolts? Most everything on the car is actually Torx.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #22
All Solved

Rudeney YOU are a genius. It was a torx 5 and i couldnt do anything to the electronics (Probably a chip gone wrong).
I bit the bullet and got another gearshift unit and BINGO !. Your oridginal diagnosis was correct the car is now working A.O.K.
Many thanks and lots of gratitude for your time and advice.
Regards Cass
"When you are dead you dont know that you are dead, but if affects other people. Stupidity is the same":laugh
 

·
Coupe/Convertible Forums Moderator
Joined
·
18,857 Posts
Glad to hear you got it working!
 

·
Registered
Joined
·
1 Posts
Need help, I purchased a 2000 w220 s430 with the air-matic failed, I put aftermarket strut kit on it, car ride and drive good, out of the blue it started a no Shift then wouldn't go in park unless i move my foot off the brake, PS is still in the cluster, but turn off car and restart no PS gear, car is also draining battery down and struggling to charge some times I replaced AGM battery, alternator, conductor plate and plug, starter and battery junction pre-fuse box and no change, PS will show if voltage is up, and also tag and 3rd brake light not working could it be a SAM if so which one, some one or two or three please help, open to any subjections
 

·
Registered
Joined
·
4 Posts
I have similar fault on SL55.
The dash display initially shows P but shortly after shows R thereby inhibiting startup.

My LAUNCH diagnostics straight away points to the ESM
The only fault showing is P1925 which means Drive Authorisation has been refused by N15/5 ESM gear select module.

We've ordered a used one.

Can you guys tell me if it needs coding into my car or will I have to swap the eeprom over (8 pin chip next to the microcontroller)

What a pain getting to the ESM PCB in the gear lever.
Typical German engineering where all the parts are interlocked with eachother necessitating complete dismantling just to get at one part !!!!
 

·
Coupe/Convertible Forums Moderator
Joined
·
18,857 Posts
I have similar fault on SL55.
The dash display initially shows P but shortly after shows R thereby inhibiting startup.

My LAUNCH diagnostics straight away points to the ESM
The only fault showing is P1925 which means Drive Authorisation has been refused by N15/5 ESM gear select module.

We've ordered a used one.

Can you guys tell me if it needs coding into my car or will I have to swap the eeprom over (8 pin chip next to the microcontroller)

What a pain getting to the ESM PCB in the gear lever.
Typical German engineering where all the parts are interlocked with eachother necessitating complete dismantling just to get at one part !!!!
Welcome to the forum! Please take a moment to visit the User Control Panel and update your profile to include your car model and year, and your location (at least country). This information will then appear below your name and avatar on the left side panel next to each post you make. This will greatly help others to give you better information. If you are using the mobile version of the site, you will need to switch to the "full" version to get to the User Control Panel.

One thing to check is the linkage under the car between the shifter and transmission. It could be slightly out of adjustment. Another thing - you should post in the R230 forum as that will be more relevant information for your car.
 
21 - 27 of 27 Posts
Top