Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
Hi all,
I have noticed a strange issue with the dash lights not coming on upon turning the car on. It's the wife's car, an 03 CLK 430 Cab. They seem to come on after a random amount of time from the car being started. Anyone have any similar issues with this or have an idea what could be causing it? Thanks


Steve
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
Does anyone have any advice on how to go about trouble-shooting this issue(see my above post)? I turn the headlights on and the dash lights do not illuminate immediately. It seems they come on after a long while, like a few minutes, at least, if at all. Is there anyone out there who has had the same or similar issue?

Steve
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,385 Posts
Steve - the absence of any response suggests that none of us have had this exact problem.

However, I have had an illumination problem that comes & goes. Mine concerns the illuminated pushbuttons on my steering wheel, and last year 2 of them decided not to come on with the rest of the interior lamps. As investigating the wiring contacts meant pulling the airbag system out, I ignored it. Then it suddenly came good all on it's own, and has stayed OK. :)

I'm sure that your problem is a bad connection, probably at the power connection to the circuit board that the instrument cluster lamps are plugged into.

There are other posts that cover the removal of this item. You need to obtain/make a couple of hooks to pull the cluster forward & out. :thumbsup:
 
1 - 3 of 3 Posts
Top